aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-20 20:30:04 +0100
committerFelix Fietkau <nbd@openwrt.org>2016-01-20 21:56:03 +0100
commit9f8e5aca342c806d1031e063b00a0045e0eb6c57 (patch)
treee9547c4e7c77f1db6e1ea8c9c96b36ee548f641f
parentf12aae60ad661a67b45ef4370757fa5236ffffff (diff)
treewide: use $(STAGING_DIR)/host instead of $(STAGING_DIR_HOST), sync with changes in trunk
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
-rw-r--r--admin/sudo/Makefile4
-rw-r--r--admin/sudo/patches/010-cross-compile-fixes.patch15
-rw-r--r--lang/lualanes/Makefile4
-rw-r--r--lang/luarocks/Makefile2
-rw-r--r--lang/node-arduino-firmata/Makefile2
-rw-r--r--lang/node-cylon/Makefile2
-rw-r--r--lang/node-hid/Makefile2
-rw-r--r--lang/node-serialport/Makefile2
-rw-r--r--lang/node/Makefile2
-rw-r--r--lang/perl-xml-parser/Makefile4
-rw-r--r--lang/perl/Makefile2
-rw-r--r--lang/perl/perlmod.mk6
-rw-r--r--lang/php5/Makefile8
-rw-r--r--lang/php5/pecl.mk4
-rw-r--r--lang/python-cffi/Makefile2
-rw-r--r--lang/python-ply/Makefile2
-rw-r--r--lang/python-pycparser/Makefile2
-rw-r--r--lang/python-setuptools/Makefile2
-rw-r--r--lang/python/Makefile16
-rw-r--r--lang/python/files/python-host.mk8
-rw-r--r--lang/python/files/python-package.mk4
-rw-r--r--lang/python3/Makefile12
-rw-r--r--lang/python3/files/python3-package.mk4
-rw-r--r--libs/boost/Makefile4
-rw-r--r--libs/libgee/Makefile4
-rw-r--r--libs/libmraa/Makefile4
-rw-r--r--libs/libsearpc/Makefile4
-rw-r--r--libs/libupm/Makefile4
-rw-r--r--libs/libzdb/Makefile4
-rw-r--r--libs/libzdb/patches/020-filterh-use-host-built-version.patch2
-rw-r--r--libs/protobuf/Makefile2
-rw-r--r--multimedia/grilo/Makefile4
-rw-r--r--net/nfs-kernel-server/Makefile7
-rw-r--r--utils/dbus/Makefile8
34 files changed, 75 insertions, 83 deletions
diff --git a/admin/sudo/Makefile b/admin/sudo/Makefile
index 3f2d6f81a..43e92977d 100644
--- a/admin/sudo/Makefile
+++ b/admin/sudo/Makefile
@@ -64,8 +64,8 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
- $(CP) $(HOST_BUILD_DIR)/lib/util/mksig{list,name} $(STAGING_DIR_HOST)/bin/
+ $(INSTALL_DIR) $(STAGING_DIR)/host/bin
+ $(CP) $(HOST_BUILD_DIR)/lib/util/mksig{list,name} $(STAGING_DIR)/host/bin/
endef
$(eval $(call HostBuild))
diff --git a/admin/sudo/patches/010-cross-compile-fixes.patch b/admin/sudo/patches/010-cross-compile-fixes.patch
index 4e80d4d42..b9c1e7995 100644
--- a/admin/sudo/patches/010-cross-compile-fixes.patch
+++ b/admin/sudo/patches/010-cross-compile-fixes.patch
@@ -1,25 +1,16 @@
diff -rupN sudo-1.8.11p2.orig/lib/util/Makefile.in sudo-1.8.11p2/lib/util/Makefile.in
--- sudo-1.8.11p2.orig/lib/util/Makefile.in 2014-10-07 22:26:20.000000000 +0200
+++ sudo-1.8.11p2/lib/util/Makefile.in 2014-12-09 21:44:35.610041162 +0100
-@@ -17,6 +17,8 @@
- # @configure_input@
- #
-
-+include $(TOPDIR)/rules.mk
-+
- #### Start of system configuration section. ####
-
- srcdir = @srcdir@
-@@ -142,10 +144,10 @@ libsudo_util.la: $(LTOBJS) @LT_LDDEP@
+@@ -142,10 +142,10 @@ libsudo_util.la: $(LTOBJS) @LT_LDDEP@
esac
siglist.c: mksiglist
- ./mksiglist > $@
-+ $(STAGING_DIR_HOST)/bin/mksiglist > $@
++ mksiglist > $@
signame.c: mksigname
- ./mksigname > $@
-+ $(STAGING_DIR_HOST)/bin/mksigname > $@
++ mksigname > $@
mksiglist: $(srcdir)/mksiglist.c $(srcdir)/mksiglist.h $(incdir)/sudo_compat.h $(top_builddir)/config.h
$(CC) $(CPPFLAGS) $(CFLAGS) $(DEFS) $(srcdir)/mksiglist.c -o $@
diff --git a/lang/lualanes/Makefile b/lang/lualanes/Makefile
index 06bc1e286..616129066 100644
--- a/lang/lualanes/Makefile
+++ b/lang/lualanes/Makefile
@@ -42,8 +42,8 @@ endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) all \
CC="$(TARGET_CC)" \
- LUA="$(STAGING_DIR_HOST)/bin/lua" \
- LUAC="$(STAGING_DIR_HOST)/bin/luac" \
+ LUA="$(STAGING_DIR)/host/bin/lua" \
+ LUAC="$(STAGING_DIR)/host/bin/luac" \
OPT_FLAGS="$(TARGET_CFLAGS) --std=c99 -Dpthread_yield=sched_yield"
endef
diff --git a/lang/luarocks/Makefile b/lang/luarocks/Makefile
index e0a0f5711..7519f8f7c 100644
--- a/lang/luarocks/Makefile
+++ b/lang/luarocks/Makefile
@@ -41,7 +41,7 @@ endef
CONFIGURE_ARGS = \
--prefix=$(CONFIGURE_PREFIX) \
--sysconfdir=/etc \
- --with-lua=$(STAGING_DIR_HOST)
+ --with-lua=$(STAGING_DIR)/host
define Build/Compile
$(call Build/Compile/Default,build)
diff --git a/lang/node-arduino-firmata/Makefile b/lang/node-arduino-firmata/Makefile
index aced07012..82310d4c2 100644
--- a/lang/node-arduino-firmata/Makefile
+++ b/lang/node-arduino-firmata/Makefile
@@ -53,7 +53,7 @@ define Build/Compile
npm_config_arch=$(CONFIG_ARCH) \
npm_config_nodedir=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/ \
PREFIX="$(PKG_INSTALL_DIR)/usr/" \
- $(STAGING_DIR_HOST)/bin/npm install -g $(PKG_BUILD_DIR)
+ $(STAGING_DIR)/host/bin/npm install -g $(PKG_BUILD_DIR)
endef
define Package/node-arduino-firmata/install
diff --git a/lang/node-cylon/Makefile b/lang/node-cylon/Makefile
index 753ae2319..d2e40b277 100644
--- a/lang/node-cylon/Makefile
+++ b/lang/node-cylon/Makefile
@@ -68,7 +68,7 @@ define Build/Compile
npm_config_arch=$(CONFIG_ARCH) \
npm_config_nodedir=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/ \
PREFIX="$(PKG_INSTALL_DIR)/usr/" \
- $(STAGING_DIR_HOST)/bin/npm install -g $(PKG_BUILD_DIR)
+ $(STAGING_DIR)/host/bin/npm install -g $(PKG_BUILD_DIR)
endef
define Package/node-cylon/install
diff --git a/lang/node-hid/Makefile b/lang/node-hid/Makefile
index 911e2a4cc..620fc29d7 100644
--- a/lang/node-hid/Makefile
+++ b/lang/node-hid/Makefile
@@ -50,7 +50,7 @@ define Build/Compile
npm_config_arch=$(CONFIG_ARCH) \
npm_config_nodedir=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/ \
PREFIX="$(PKG_INSTALL_DIR)/usr/" \
- $(STAGING_DIR_HOST)/bin/npm install -g $(PKG_BUILD_DIR)
+ $(STAGING_DIR)/host/bin/npm install -g $(PKG_BUILD_DIR)
endef
define Package/node-hid/install
diff --git a/lang/node-serialport/Makefile b/lang/node-serialport/Makefile
index ad4b7aff6..c73e85848 100644
--- a/lang/node-serialport/Makefile
+++ b/lang/node-serialport/Makefile
@@ -50,7 +50,7 @@ define Build/Compile
npm_config_arch=$(CONFIG_ARCH) \
npm_config_nodedir=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/ \
PREFIX="$(PKG_INSTALL_DIR)/usr/" \
- $(STAGING_DIR_HOST)/bin/npm install -g $(PKG_BUILD_DIR)
+ $(STAGING_DIR)/host/bin/npm install -g $(PKG_BUILD_DIR)
endef
define Package/node-serialport/install
diff --git a/lang/node/Makefile b/lang/node/Makefile
index 147410499..9df887614 100644
--- a/lang/node/Makefile
+++ b/lang/node/Makefile
@@ -57,7 +57,7 @@ HOST_CONFIGURE_VARS:=
HOST_CONFIGURE_ARGS:= \
--dest-os=linux \
--without-snapshot \
- --prefix=$(STAGING_DIR_HOST)/
+ --prefix=$(STAGING_DIR)/host/
HOST_CONFIGURE_CMD:=python ./configure
diff --git a/lang/perl-xml-parser/Makefile b/lang/perl-xml-parser/Makefile
index 08acb239f..e5d3b2c88 100644
--- a/lang/perl-xml-parser/Makefile
+++ b/lang/perl-xml-parser/Makefile
@@ -25,8 +25,8 @@ HOST_BUILD_DEPENDS:=perl/host expat/host
EXPAT_LIBPATH:=$(STAGING_DIR)/usr/lib
EXPAT_INCPATH=$(STAGING_DIR)/usr/include
-HOST_EXPAT_LIBPATH:=$(STAGING_DIR_HOST)/lib
-HOST_EXPAT_INCPATH=$(STAGING_DIR_HOST)/include
+HOST_EXPAT_LIBPATH:=$(STAGING_DIR)/host/lib
+HOST_EXPAT_INCPATH=$(STAGING_DIR)/host/include
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
diff --git a/lang/perl/Makefile b/lang/perl/Makefile
index 39a018ad9..c1c51f7a8 100644
--- a/lang/perl/Makefile
+++ b/lang/perl/Makefile
@@ -35,7 +35,7 @@ PKG_BUILD_PARALLEL:=1
HOST_BUILD_PARALLEL:=1
# Variables used during configuration/build
-HOST_PERL_PREFIX:=$(STAGING_DIR_HOST)/usr
+HOST_PERL_PREFIX:=$(STAGING_DIR)/host/usr
# Filter -g3, it will break Compress-Raw-Zlib
TARGET_CFLAGS_PERL:=$(patsubst -g3,-g,$(TARGET_CFLAGS))
diff --git a/lang/perl/perlmod.mk b/lang/perl/perlmod.mk
index a6f4eaaf9..c64942fed 100644
--- a/lang/perl/perlmod.mk
+++ b/lang/perl/perlmod.mk
@@ -4,12 +4,12 @@
PERL_VERSION:=5.22
# Build environment
-HOST_PERL_PREFIX:=$(STAGING_DIR_HOST)/usr
+HOST_PERL_PREFIX:=$(STAGING_DIR)/host/usr
ifneq ($(CONFIG_USE_GLIBC),)
EXTRA_LIBS:=bsd
EXTRA_LIBDIRS:=$(STAGING_DIR)/lib
endif
-PERL_CMD:=$(STAGING_DIR_HOST)/usr/bin/perl$(PERL_VERSION).0
+PERL_CMD:=$(STAGING_DIR)/host/usr/bin/perl$(PERL_VERSION).0
MOD_CFLAGS_PERL:=-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 $(TARGET_CFLAGS) $(TARGET_CPPFLAGS)
ifdef CONFIG_PERL_THREADS
@@ -26,7 +26,7 @@ define perlmod/host/relink
rm -f $(1)/Makefile.aperl
$(MAKE) -C $(1) perl
$(CP) $(1)/perl $(PERL_CMD)
- $(CP) $(1)/perl $(STAGING_DIR_HOST)/usr/bin/perl
+ $(CP) $(1)/perl $(STAGING_DIR)/host/usr/bin/perl
endef
define perlmod/host/Configure
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 17314cfeb..9d02a2d29 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -491,10 +491,10 @@ define Build/InstallDev
mkdir -p $(PKG_BUILD_DIR)/staging/usr/bin
make -C $(PKG_BUILD_DIR) install INSTALL_ROOT=$(PKG_BUILD_DIR)/staging
rm -f $(PKG_BUILD_DIR)/staging/usr/bin/php
- $(CP) $(PKG_BUILD_DIR)/staging/* $(STAGING_DIR_HOST)
- sed -i -e "s#prefix='/usr'#prefix='$(STAGING_DIR_HOST)/usr'#" $(STAGING_DIR_HOST)/usr/bin/phpize
- sed -i -e "s#exec_prefix=\"\`eval echo /usr\`\"#exec_prefix='$(STAGING_DIR_HOST)/usr'#" $(STAGING_DIR_HOST)/usr/bin/phpize
- sed -i -e "s#prefix=\"/usr\"#prefix=\"$(STAGING_DIR_HOST)/usr\"#" $(STAGING_DIR_HOST)/usr/bin/php-config
+ $(CP) $(PKG_BUILD_DIR)/staging/* $(STAGING_DIR)/host
+ sed -i -e "s#prefix='/usr'#prefix='$(STAGING_DIR)/host/usr'#" $(STAGING_DIR)/host/usr/bin/phpize
+ sed -i -e "s#exec_prefix=\"\`eval echo /usr\`\"#exec_prefix='$(STAGING_DIR)/host/usr'#" $(STAGING_DIR)/host/usr/bin/phpize
+ sed -i -e "s#prefix=\"/usr\"#prefix=\"$(STAGING_DIR)/host/usr\"#" $(STAGING_DIR)/host/usr/bin/php-config
endef
define BuildModule
diff --git a/lang/php5/pecl.mk b/lang/php5/pecl.mk
index ee2a5ce77..88d3a98bb 100644
--- a/lang/php5/pecl.mk
+++ b/lang/php5/pecl.mk
@@ -15,11 +15,11 @@ endef
define Build/Prepare
$(Build/Prepare/Default)
- ( cd $(PKG_BUILD_DIR); $(STAGING_DIR_HOST)/usr/bin/phpize )
+ ( cd $(PKG_BUILD_DIR); $(STAGING_DIR)/host/usr/bin/phpize )
endef
CONFIGURE_ARGS+= \
- --with-php-config=$(STAGING_DIR_HOST)/usr/bin/php-config
+ --with-php-config=$(STAGING_DIR)/host/usr/bin/php-config
define PECLPackage
diff --git a/lang/python-cffi/Makefile b/lang/python-cffi/Makefile
index b78bce1d5..b418bc151 100644
--- a/lang/python-cffi/Makefile
+++ b/lang/python-cffi/Makefile
@@ -45,7 +45,7 @@ define Build/Compile
endef
define Host/Compile
- $(call Build/Compile/HostPyMod,,install --prefix="/usr" --root="$(STAGING_DIR_HOST)")
+ $(call Build/Compile/HostPyMod,,install --prefix="/usr" --root="$(STAGING_DIR)/host")
endef
define Host/Install
diff --git a/lang/python-ply/Makefile b/lang/python-ply/Makefile
index e8b974a68..5f1a95dd3 100644
--- a/lang/python-ply/Makefile
+++ b/lang/python-ply/Makefile
@@ -53,7 +53,7 @@ define Build/InstallDev
endef
define Host/Compile
- $(call Build/Compile/HostPyMod,,install --prefix="/usr" --root="$(STAGING_DIR_HOST)")
+ $(call Build/Compile/HostPyMod,,install --prefix="/usr" --root="$(STAGING_DIR)/host")
endef
define Host/Install
diff --git a/lang/python-pycparser/Makefile b/lang/python-pycparser/Makefile
index c5e03f2bb..b657cd819 100644
--- a/lang/python-pycparser/Makefile
+++ b/lang/python-pycparser/Makefile
@@ -47,7 +47,7 @@ define Build/Compile
endef
define Host/Compile
- $(call Build/Compile/HostPyMod,,install --prefix="/usr" --root="$(STAGING_DIR_HOST)")
+ $(call Build/Compile/HostPyMod,,install --prefix="/usr" --root="$(STAGING_DIR)/host")
endef
define Host/Install
diff --git a/lang/python-setuptools/Makefile b/lang/python-setuptools/Makefile
index 71d30fec1..b45b408e1 100644
--- a/lang/python-setuptools/Makefile
+++ b/lang/python-setuptools/Makefile
@@ -60,7 +60,7 @@ endef
define Host/Compile
$(call Build/Compile/HostPyMod,,\
- install --root="$(STAGING_DIR_HOST)" --prefix="/usr" \
+ install --root="$(STAGING_DIR)/host" --prefix="/usr" \
--single-version-externally-managed \
)
endef
diff --git a/lang/python/Makefile b/lang/python/Makefile
index c8936d226..a75676964 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -144,13 +144,13 @@ define Build/InstallDev
$(PKG_INSTALL_DIR)/usr/include/python$(PYTHON_VERSION) \
$(1)/usr/include/
$(CP) \
- $(STAGING_DIR_HOST)/usr/lib/python$(PYTHON_VERSION) \
+ $(STAGING_DIR)/host/usr/lib/python$(PYTHON_VERSION) \
$(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* \
$(1)/usr/lib/
$(CP) \
- $(STAGING_DIR_HOST)/lib/pkgconfig/python.pc \
- $(STAGING_DIR_HOST)/lib/pkgconfig/python2.pc \
- $(STAGING_DIR_HOST)/lib/pkgconfig/python-$(PYTHON_VERSION).pc \
+ $(STAGING_DIR)/host/lib/pkgconfig/python.pc \
+ $(STAGING_DIR)/host/lib/pkgconfig/python2.pc \
+ $(STAGING_DIR)/host/lib/pkgconfig/python-$(PYTHON_VERSION).pc \
$(1)/usr/lib/pkgconfig
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION)/config \
@@ -221,16 +221,16 @@ HOST_CONFIGURE_ARGS+= \
--without-cxx-main \
--without-pymalloc \
--with-threads \
- --prefix=$(STAGING_DIR_HOST)/usr \
- --with-system-expat=$(STAGING_DIR_HOST) \
+ --prefix=$(STAGING_DIR)/host/usr \
+ --with-system-expat=$(STAGING_DIR)/host \
--with-ensurepip=upgrade \
CONFIG_SITE= \
CFLAGS="$(HOST_CFLAGS)"
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+ $(INSTALL_DIR) $(STAGING_DIR)/host/bin/
$(MAKE) -C $(HOST_BUILD_DIR) install
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/Parser/pgen $(STAGING_DIR_HOST)/bin/pgen2
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/Parser/pgen $(STAGING_DIR)/host/bin/pgen2
endef
$(eval $(call HostBuild))
diff --git a/lang/python/files/python-host.mk b/lang/python/files/python-host.mk
index b2ed33683..65d9ca51a 100644
--- a/lang/python/files/python-host.mk
+++ b/lang/python/files/python-host.mk
@@ -5,15 +5,15 @@
# See /LICENSE for more information.
#
-HOST_PYTHON_INC_DIR:=$(STAGING_DIR_HOST)/include/python$(PYTHON_VERSION)
+HOST_PYTHON_INC_DIR:=$(STAGING_DIR)/host/include/python$(PYTHON_VERSION)
HOST_PYTHON_PKG_DIR:=/usr/lib/python$(PYTHON_VERSION)/site-packages
-HOST_PYTHONPATH:=$(HOST_PYTHON_LIB_DIR):$(STAGING_DIR_HOST)/$(HOST_PYTHON_PKG_DIR)
+HOST_PYTHONPATH:=$(HOST_PYTHON_LIB_DIR):$(STAGING_DIR)/host/$(HOST_PYTHON_PKG_DIR)
define HostPython
if [ "$(strip $(3))" == "HOST" ]; then \
export PYTHONPATH="$(HOST_PYTHONPATH)"; \
- export _python_sysroot="$(STAGING_DIR_HOST)"; \
+ export _python_sysroot="$(STAGING_DIR)/host"; \
else \
export PYTHONPATH="$(PYTHONPATH)"; \
export _python_sysroot="$(STAGING_DIR)"; \
@@ -29,7 +29,7 @@ endef
# These configure args are needed in detection of path to Python header files
# using autotools.
HOST_CONFIGURE_ARGS += \
- _python_sysroot="$(STAGING_DIR_HOST)" \
+ _python_sysroot="$(STAGING_DIR)/host" \
_python_prefix="/usr" \
_python_exec_prefix="/usr"
diff --git a/lang/python/files/python-package.mk b/lang/python/files/python-package.mk
index 0a370c531..e8c049224 100644
--- a/lang/python/files/python-package.mk
+++ b/lang/python/files/python-package.mk
@@ -17,8 +17,8 @@ PYTHON_PKG_DIR:=/usr/lib/python$(PYTHON_VERSION)/site-packages
PYTHON:=python$(PYTHON_VERSION)
-HOST_PYTHON_LIB_DIR:=$(STAGING_DIR_HOST)/usr/lib/python$(PYTHON_VERSION)
-HOST_PYTHON_BIN:=$(STAGING_DIR_HOST)/bin/python2
+HOST_PYTHON_LIB_DIR:=$(STAGING_DIR)/host/usr/lib/python$(PYTHON_VERSION)
+HOST_PYTHON_BIN:=$(STAGING_DIR)/host/bin/python2
PYTHONPATH:=$(PYTHON_LIB_DIR):$(STAGING_DIR)/$(PYTHON_PKG_DIR):$(PKG_INSTALL_DIR)/$(PYTHON_PKG_DIR)
diff --git a/lang/python3/Makefile b/lang/python3/Makefile
index 250410756..cdaa93a09 100644
--- a/lang/python3/Makefile
+++ b/lang/python3/Makefile
@@ -146,7 +146,7 @@ define Build/InstallDev
$(PKG_INSTALL_DIR)/usr/include/python$(PYTHON_VERSION) \
$(1)/usr/include/
$(CP) \
- $(STAGING_DIR_HOST)/lib/python$(PYTHON_VERSION) \
+ $(STAGING_DIR)/host/lib/python$(PYTHON_VERSION) \
$(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* \
$(1)/usr/lib/
$(CP) \
@@ -216,8 +216,8 @@ HOST_CONFIGURE_ARGS+= \
--without-cxx-main \
--without-pymalloc \
--with-threads \
- --prefix=$(STAGING_DIR_HOST) \
- --with-system-expat=$(STAGING_DIR_HOST) \
+ --prefix=$(STAGING_DIR)/host \
+ --with-system-expat=$(STAGING_DIR)/host \
--with-ensurepip=upgrade \
CONFIG_SITE= \
CFLAGS="$(HOST_CFLAGS)"
@@ -228,10 +228,10 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+ $(INSTALL_DIR) $(STAGING_DIR)/host/bin/
$(MAKE) -C $(HOST_BUILD_DIR) install
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/Parser/pgen $(STAGING_DIR_HOST)/bin/pgen3
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/Programs/_freeze_importlib $(STAGING_DIR_HOST)/bin/_freeze_importlib
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/Parser/pgen $(STAGING_DIR)/host/bin/pgen3
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/Programs/_freeze_importlib $(STAGING_DIR)/host/bin/_freeze_importlib
endef
$(eval $(call HostBuild))
diff --git a/lang/python3/files/python3-package.mk b/lang/python3/files/python3-package.mk
index 4fd3191eb..4ffb18175 100644
--- a/lang/python3/files/python3-package.mk
+++ b/lang/python3/files/python3-package.mk
@@ -20,8 +20,8 @@ PYTHON3_PKG_DIR:=/usr/lib/python$(PYTHON3_VERSION)/site-packages
PYTHON3:=python$(PYTHON3_VERSION)
-HOST_PYTHON3_LIB_DIR:=$(STAGING_DIR_HOST)/lib/python$(PYTHON3_VERSION)
-HOST_PYTHON3_BIN:=$(STAGING_DIR_HOST)/bin/python3
+HOST_PYTHON3_LIB_DIR:=$(STAGING_DIR)/host/lib/python$(PYTHON3_VERSION)
+HOST_PYTHON3_BIN:=$(STAGING_DIR)/host/bin/python3
PYTHON3PATH:=$(PYTHON3_LIB_DIR):$(STAGING_DIR)/$(PYTHON3_PKG_DIR):$(PKG_INSTALL_DIR)/$(PYTHON3_PKG_DIR)
define HostPython3
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index ecd65fa3b..3c488ce71 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -397,11 +397,11 @@ endef
define Host/Install
$(INSTALL_DIR) \
- $(STAGING_DIR_HOST)/bin
+ $(STAGING_DIR)/host/bin
$(CP) \
$(HOST_BUILD_DIR)/tools/build/src/engine/bin.*/b2 \
- $(STAGING_DIR_HOST)/bin/
+ $(STAGING_DIR)/host/bin/
endef
define Package/boost/Default/install
diff --git a/libs/libgee/Makefile b/libs/libgee/Makefile
index d03a79d4f..9be56482d 100644
--- a/libs/libgee/Makefile
+++ b/libs/libgee/Makefile
@@ -57,10 +57,10 @@ define Build/InstallDev
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
$(1)/usr/lib/pkgconfig/
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/vala-0.30/vapi/
+ $(INSTALL_DIR) $(STAGING_DIR)/host/share/vala-0.30/vapi/
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/share/vala/vapi/* \
- $(STAGING_DIR_HOST)/share/vala-0.30/vapi
+ $(STAGING_DIR)/host/share/vala-0.30/vapi
endef
define Package/libgee/install
diff --git a/libs/libmraa/Makefile b/libs/libmraa/Makefile
index 3e3202ad2..1bff5ff99 100644
--- a/libs/libmraa/Makefile
+++ b/libs/libmraa/Makefile
@@ -28,8 +28,8 @@ include $(INCLUDE_DIR)/cmake.mk
CMAKE_OPTIONS=-DBUILDARCH=$(CONFIG_ARCH) \
-DENABLEEXAMPLES=0 \
- -DNODE_EXECUTABLE=$(STAGING_DIR_HOST)/bin/node \
- -DSWIG_DIR=$(STAGING_DIR_HOST)/bin
+ -DNODE_EXECUTABLE=$(STAGING_DIR)/host/bin/node \
+ -DSWIG_DIR=$(STAGING_DIR)/host/bin
TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/include/node
diff --git a/libs/libsearpc/Makefile b/libs/libsearpc/Makefile
index 4ec9e93a0..15c0e8ba3 100644
--- a/libs/libsearpc/Makefile
+++ b/libs/libsearpc/Makefile
@@ -52,8 +52,8 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/lib/searpc-codegen.py $(STAGING_DIR_HOST)/bin/
+ $(INSTALL_DIR) $(STAGING_DIR)/host/bin
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/lib/searpc-codegen.py $(STAGING_DIR)/host/bin/
endef
$(eval $(call HostBuild))
diff --git a/libs/libupm/Makefile b/libs/libupm/Makefile
index 93287c52d..c1eaad16e 100644
--- a/libs/libupm/Makefile
+++ b/libs/libupm/Makefile
@@ -36,8 +36,8 @@ UPM_MODULES:= \
th02 tm1637 tsl2561 ttp223 ublox6 uln200xa waterlevel wheelencoder wt5001 yg1006 zfm20
CMAKE_OPTIONS=-DBUILDARCH=$(CONFIG_ARCH) \
- -DNODE_EXECUTABLE=$(STAGING_DIR_HOST)/bin/node \
- -DSWIG_DIR=$(STAGING_DIR_HOST)/bin
+ -DNODE_EXECUTABLE=$(STAGING_DIR)/host/bin/node \
+ -DSWIG_DIR=$(STAGING_DIR)/host/bin
define Package/libupm/Default
SECTION:=libs
diff --git a/libs/libzdb/Makefile b/libs/libzdb/Makefile
index f3fc66eed..cf17a2cff 100644
--- a/libs/libzdb/Makefile
+++ b/libs/libzdb/Makefile
@@ -67,8 +67,8 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
- $(CP) $(HOST_BUILD_DIR)/tools/bin/filterh $(STAGING_DIR_HOST)/bin/
+ $(INSTALL_DIR) $(STAGING_DIR)/host/bin
+ $(CP) $(HOST_BUILD_DIR)/tools/bin/filterh $(STAGING_DIR)/host/bin/
endef
$(eval $(call HostBuild))
diff --git a/libs/libzdb/patches/020-filterh-use-host-built-version.patch b/libs/libzdb/patches/020-filterh-use-host-built-version.patch
index 74c166a6c..1edfd77b3 100644
--- a/libs/libzdb/patches/020-filterh-use-host-built-version.patch
+++ b/libs/libzdb/patches/020-filterh-use-host-built-version.patch
@@ -14,7 +14,7 @@ diff -rupN libzdb-3.0.orig/Makefile.am libzdb-3.0/Makefile.am
RE2C = @RE2C@
RE2CFLAGS = -b
-FILTERH = ./tools/bin/filterh
-+FILTERH = $(STAGING_DIR_HOST)/bin/filterh
++FILTERH = $(STAGING_DIR)/host/bin/filterh
AM_CPPFLAGS = $(CPPFLAGS) $(DBCPPFLAGS)
AM_CPPFLAGS += -Isrc -Isrc/util -Isrc/net -Isrc/db -Isrc/exceptions
diff --git a/libs/protobuf/Makefile b/libs/protobuf/Makefile
index 72133be86..1e70a12fc 100644
--- a/libs/protobuf/Makefile
+++ b/libs/protobuf/Makefile
@@ -41,7 +41,7 @@ define Package/protobuf/description
of its internal RPC protocols and file formats.
endef
-CONFIGURE_ARGS += --with-protoc=$(STAGING_DIR_HOST)/bin/protoc
+CONFIGURE_ARGS += --with-protoc=$(STAGING_DIR)/host/bin/protoc
define Build/InstallDev
$(INSTALL_DIR) \
diff --git a/multimedia/grilo/Makefile b/multimedia/grilo/Makefile
index 960d409b2..7e78e3dbe 100644
--- a/multimedia/grilo/Makefile
+++ b/multimedia/grilo/Makefile
@@ -56,13 +56,13 @@ define Build/InstallDev
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
$(1)/usr/lib/pkgconfig/
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/vala-0.30/vapi/
+ $(INSTALL_DIR) $(STAGING_DIR)/host/share/vala-0.30/vapi/
# Note: this are compiled elsewhere because grilo refuses to
# generate VAPI files unless gobject-introspection exists;
# OpenWrt does not yet have a gobject-introspection package.
$(INSTALL_DATA) \
./files/*.vapi \
- $(STAGING_DIR_HOST)/share/vala-0.30/vapi
+ $(STAGING_DIR)/host/share/vala-0.30/vapi
endef
define Package/grilo/install
diff --git a/net/nfs-kernel-server/Makefile b/net/nfs-kernel-server/Makefile
index 8c2d26daa..eadcf128a 100644
--- a/net/nfs-kernel-server/Makefile
+++ b/net/nfs-kernel-server/Makefile
@@ -93,8 +93,8 @@ MAKE_FLAGS += \
OPT="$(TARGET_CFLAGS)" \
INSTALLSUID="install -m 4755" \
DESTDIR="$(PKG_INSTALL_DIR)" \
- RPCGEN_PATH=$(STAGING_DIR_HOST)/bin/rpcgen \
- RPCGEN=$(STAGING_DIR_HOST)/bin/rpcgen
+ RPCGEN_PATH=$(STAGING_DIR)/host/bin/rpcgen \
+ RPCGEN=$(STAGING_DIR)/host/bin/rpcgen
HOST_CFLAGS += -Dlinux
@@ -125,7 +125,8 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/tools/rpcgen/rpcgen $(STAGING_DIR_HOST)/bin/rpcgen
+ $(INSTALL_DIR) $(STAGING_DIR)/host/bin
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/tools/rpcgen/rpcgen $(STAGING_DIR)/host/bin/rpcgen
endef
define Package/nfs-kernel-server/install
diff --git a/utils/dbus/Makefile b/utils/dbus/Makefile
index 2cc6033d0..16ed227e2 100644
--- a/utils/dbus/Makefile
+++ b/utils/dbus/Makefile
@@ -122,11 +122,11 @@ HOST_CONFIGURE_ARGS+= \
--disable-verbose-mode \
--disable-xml-docs \
--with-dbus-user=root \
- --with-dbus-daemondir="$(STAGIND_DIR_HOST)/bin" \
- --with-system-socket="$(STAGING_DIR_HOST)/var/run/dbus/system_bus_socket" \
- --with-system-pid-file="$(STAGING_DIR_HOST)/var/run/dbus.pid" \
+ --with-dbus-daemondir="$(STAGIND_DIR)/host/bin" \
+ --with-system-socket="$(STAGING_DIR)/host/var/run/dbus/system_bus_socket" \
+ --with-system-pid-file="$(STAGING_DIR)/host/var/run/dbus.pid" \
--without-x \
- --libexecdir="$(STAGING_DIR_HOST)/lib/dbus-1"
+ --libexecdir="$(STAGING_DIR)/host/lib/dbus-1"
HOST_CONFIGURE_VARS+= \
ac_cv_have_abstract_sockets="yes" \