aboutsummaryrefslogtreecommitdiff
path: root/net/socat
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2017-01-17 15:42:19 -0500
committerGitHub <noreply@github.com>2017-01-17 15:42:19 -0500
commit646f85cce6e963bd12cc609345d2e1d5e4043fae (patch)
treec6b089f798e654b87ee50f7ea05faf97de575378 /net/socat
parent94a8fef2223e4b958a8fbbf46b47f3f4eae7aba7 (diff)
parent5e0596b541150c1569d50880c115a0fdb9a54cbe (diff)
Merge pull request #3863 from jow-/socat-fix-build
socat: work around missing stddef.h include
Diffstat (limited to 'net/socat')
-rw-r--r--net/socat/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index 825edf10c..ede942c35 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -69,6 +69,9 @@ CONFIGURE_VARS += \
sc_cv_sys_tabdly_shift=11 \
sc_cv_sys_csize_shift=4
+TARGET_CFLAGS += \
+ -include stddef.h
+
define Package/socat/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/socat $(1)/usr/bin/