aboutsummaryrefslogtreecommitdiff
path: root/net/socat
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-17 21:24:12 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-17 21:24:12 +0100
commit5e0596b541150c1569d50880c115a0fdb9a54cbe (patch)
treeb9c1db6ec75ee0af5e94e3d6c7391bf336a81373 /net/socat
parenta3e7b2dc0ef11ed24dbac06ac3933e85e4d5d829 (diff)
socat: work around missing stddef.h include
The buildbots fail to build socat due to the following error: nestlex.c:14:7: error: unknown type name 'ptrdiff_t' It appears that certain source files do not include all required headers, depending on the configure options passed to socat. Work around the error by passing `-include stddef.h` via `TARGET_CFLAGS` to forcibly inject this header file into all compilation units. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'net/socat')
-rw-r--r--net/socat/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index b89ffcad2..193bebebe 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -69,6 +69,9 @@ CONFIGURE_VARS += \
sc_cv_sys_tabdly_shift=11 \
sc_cv_sys_csize_shift=4
+TARGET_CFLAGS += \
+ -include stddef.h
+
define Package/socat/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/socat $(1)/usr/bin/