aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-05 02:00:35 -0800
committerGitHub <noreply@github.com>2019-11-05 02:00:35 -0800
commitf095101399db297ce327dc3dd63e04a37c4a1ad5 (patch)
treebf93f01480753499d65c80ca9b48438a4fd3a427 /lang
parente1af55fdf51e2ce6755a3ff61338e719a5b2a3cf (diff)
parent9298aa6c8b474a6058d8de415efa1f5a520e416d (diff)
Merge pull request #10374 from peter-stadler/django-cors-headers
django-cors-headers: add python3 package
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python3-django-cors-headers/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/lang/python/python3-django-cors-headers/Makefile b/lang/python/python3-django-cors-headers/Makefile
new file mode 100644
index 000000000..7a0409f4a
--- /dev/null
+++ b/lang/python/python3-django-cors-headers/Makefile
@@ -0,0 +1,35 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=django-cors-headers
+PKG_VERSION:=3.1.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=django-cors-headers
+PKG_HASH:=5762ec9c2d59f38c76828dc1d4308baca4bc0d3e1d6f217683e7a24a1c4611a3
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Peter Stadler <peter.stadler@student.uibk.ac.at>
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-django-cors-headers
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Django application for handling the server headers required for Cross-Origin Resource Sharing (CORS).
+ URL:=https://github.com/ottoyiu/django-cors-headers
+ DEPENDS:=python3-django +python3-urllib +python3-light
+ VARIANT:=python3
+ MDEPENDS:=python3-django
+endef
+
+define Package/python3-django-cors-headers/description
+ Django application for handling the server headers required for Cross-Origin Resource Sharing (CORS).
+endef
+
+$(eval $(call Py3Package,python3-django-cors-headers))
+$(eval $(call BuildPackage,python3-django-cors-headers))
+$(eval $(call BuildPackage,python3-django-cors-headers-src))