aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPeter Stadler <peter.stadler@student.uibk.ac.at>2019-10-29 13:02:07 +0100
committerPeter Stadler <peter.stadler@student.uibk.ac.at>2019-11-01 02:38:47 +0100
commit9298aa6c8b474a6058d8de415efa1f5a520e416d (patch)
treef66ecbb88f0ed4a024512bd64765b77b3810bb05 /lang
parent5329e65e4697801a05c3725bc78cb8e4691abd98 (diff)
django-cors-headers: add python3 package
This is a dependency for the etesync-server and is using django and urllib. Signed-off-by: Peter Stadler <peter.stadler@student.uibk.ac.at>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python3-django-cors-headers/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/lang/python/python3-django-cors-headers/Makefile b/lang/python/python3-django-cors-headers/Makefile
new file mode 100644
index 000000000..7a0409f4a
--- /dev/null
+++ b/lang/python/python3-django-cors-headers/Makefile
@@ -0,0 +1,35 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=django-cors-headers
+PKG_VERSION:=3.1.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=django-cors-headers
+PKG_HASH:=5762ec9c2d59f38c76828dc1d4308baca4bc0d3e1d6f217683e7a24a1c4611a3
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Peter Stadler <peter.stadler@student.uibk.ac.at>
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-django-cors-headers
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Django application for handling the server headers required for Cross-Origin Resource Sharing (CORS).
+ URL:=https://github.com/ottoyiu/django-cors-headers
+ DEPENDS:=python3-django +python3-urllib +python3-light
+ VARIANT:=python3
+ MDEPENDS:=python3-django
+endef
+
+define Package/python3-django-cors-headers/description
+ Django application for handling the server headers required for Cross-Origin Resource Sharing (CORS).
+endef
+
+$(eval $(call Py3Package,python3-django-cors-headers))
+$(eval $(call BuildPackage,python3-django-cors-headers))
+$(eval $(call BuildPackage,python3-django-cors-headers-src))