aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-05 01:59:31 -0800
committerGitHub <noreply@github.com>2019-11-05 01:59:31 -0800
commite1af55fdf51e2ce6755a3ff61338e719a5b2a3cf (patch)
tree8573181c1290a228dbb4ce7e70853ed7adebd83d /lang
parentf24678045090841f17bbc12005d97dedc6a8c07f (diff)
parent14e51044d72d68de036fd855af35ab6ef7cbaba7 (diff)
Merge pull request #10375 from peter-stadler/sqlparse
sqlparse: add python3 package
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python3-sqlparse/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/lang/python/python3-sqlparse/Makefile b/lang/python/python3-sqlparse/Makefile
new file mode 100644
index 000000000..4df4dcd03
--- /dev/null
+++ b/lang/python/python3-sqlparse/Makefile
@@ -0,0 +1,40 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sqlparse
+PKG_VERSION:=0.3.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=sqlparse
+PKG_HASH:=7c3dca29c022744e95b547e867cee89f4fce4373f3549ccd8797d8eb52cdb873
+
+PKG_MAINTAINER:=Peter Stadler <peter.stadler@student.uibk.ac.at>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-sqlparse
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Non-validating SQL parser module.
+ URL:=https://github.com/andialbrecht/sqlparse
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-sqlparse/description
+ A non-validating SQL parser module. It provides support for parsing, splitting and formatting SQL statements.
+endef
+
+define Py3Package/python3-sqlparse/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/$(PYTHON3_PKG_DIR)/sqlparse/__main__.py \
+ $(1)/usr/bin/sqlformat
+endef
+
+$(eval $(call Py3Package,python3-sqlparse))
+$(eval $(call BuildPackage,python3-sqlparse))
+$(eval $(call BuildPackage,python3-sqlparse-src))