aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2014-11-09 19:54:01 +0200
committerAlexandru Ardelean <ardeleanalex@gmail.com>2014-11-09 20:16:25 +0200
commita9ba2161bd391e544d88705eab956054432d53e8 (patch)
treeaea7edbbf4a6bdbdd4c3b7294293196f5413cedd /lang/python
parent4f0f05f92bc89894b1e0cddfecc561539ba962fc (diff)
python: remove readline.so for now
Some symbols are not found (tgetnum and BC). Looks like the termcap lib, which should be in libncurses(w) but maybe some build param would be required. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 38e9267f9..bab6ce335 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -64,7 +64,7 @@ endef
define Package/python
$(call Package/python/Default)
- DEPENDS:=+python-base +libncursesw +libbz2 +libgdbm +libreadline +libsqlite3 +libexpat +libdb47
+ DEPENDS:=+python-base +libncursesw +libbz2 +libgdbm +libsqlite3 +libexpat +libdb47
endef
define Package/python/description
@@ -159,6 +159,7 @@ define PyPackage/python/filespec
-|/usr/lib/python$(PYTHON_VERSION)/webbrowser.py
-|/usr/lib/python$(PYTHON_VERSION)/*/test
-|/usr/lib/python$(PYTHON_VERSION)/*/tests
+-|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/readline.so
endef
define PyPackage/python-base/install