aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2014-11-09 17:56:45 +0200
committerAlexandru Ardelean <ardeleanalex@gmail.com>2014-11-09 17:56:45 +0200
commit4f0f05f92bc89894b1e0cddfecc561539ba962fc (patch)
tree8ad3e1d1a81b56af2cb7debc7cb32b1f8f8a0bbb /lang/python
parentdd4cca5d262965aa2ae81e54ae844def407e46f5 (diff)
python: add some Build/InstallDev rules back
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 058197688..38e9267f9 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -107,7 +107,19 @@ Hooks/Configure/Pre+=\
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR)/mk/
+ $(INSTALL_DIR) $(1)/usr/include/ $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/python$(PYTHON_VERSION)/
$(INSTALL_DATA) ./files/python-package.mk $(STAGING_DIR)/mk/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/python$(PYTHON_VERSION) \
+ $(1)/usr/include/
+ $(CP) \
+ $(STAGING_DIR_HOST)/lib/python$(PYTHON_VERSION) \
+ $(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* \
+ $(1)/usr/lib/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION)/config \
+ $(1)/usr/lib/python$(PYTHON_VERSION)/
endef
define PyPackage/python-base/filespec