aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-23 15:03:51 -0700
committerGitHub <noreply@github.com>2020-06-23 15:03:51 -0700
commit81dc2bd6ab8a305b7982fa411adc31ee43d138e0 (patch)
tree1f1c1e666b997c0fd2f8ce463313631484e74bca
parente9abcd74821ebdbc13356f289cc981049bafc074 (diff)
parent0df6c58f82f0b84ca08696d9d0760d425ce11917 (diff)
Merge pull request #12547 from neheb/torr
tor: remove libssp hack
-rw-r--r--net/tor/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/net/tor/Makefile b/net/tor/Makefile
index 0bac41a3e..ee6e327cf 100644
--- a/net/tor/Makefile
+++ b/net/tor/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tor
PKG_VERSION:=0.4.3.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://dist.torproject.org/ \
@@ -103,18 +103,12 @@ CONFIGURE_ARGS += \
--disable-lzma \
--disable-zstd \
--with-tor-user=tor \
- --with-tor-group=tor
+ --with-tor-group=tor \
+ --with-pic
TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
TARGET_LDFLAGS += -Wl,--gc-sections -flto
-ifneq ($(CONFIG_SSP_SUPPORT),y)
- CONFIGURE_ARGS += \
- --disable-gcc-hardening
-else
- EXTRA_CFLAGS += $(FPIC)
-endif
-
CONFIGURE_VARS += \
CROSS_COMPILE="yes"