aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-23 15:03:23 -0700
committerGitHub <noreply@github.com>2020-06-23 15:03:23 -0700
commite9abcd74821ebdbc13356f289cc981049bafc074 (patch)
treed02cd763bb42a4b70547d95711197f9d9a55ef02
parent65cba88cdfbcebda46d7627645e74848a2457419 (diff)
parent69c297971ceb86d5616f1d88a86bda6cd42d2782 (diff)
Merge pull request #12542 from neheb/opens
openssh: always enable stackprotect option
-rw-r--r--net/openssh/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/net/openssh/Makefile b/net/openssh/Makefile
index 2e9302d00..36f47e72a 100644
--- a/net/openssh/Makefile
+++ b/net/openssh/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssh
PKG_VERSION:=8.2p1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
@@ -149,7 +149,7 @@ define Package/openssh-sftp-avahi-service/conffiles
/etc/avahi/services/sftp-ssh.service
endef
-CONFIGURE_ARGS+= \
+CONFIGURE_ARGS += \
$(DISABLE_NLS) \
--sysconfdir=/etc/ssh \
--with-privsep-user=sshd \
@@ -166,7 +166,9 @@ CONFIGURE_ARGS+= \
--disable-wtmpx \
--without-bsd-auth \
--without-kerberos5 \
- --without-x
+ --without-x \
+ --with-stackprotect \
+ --with$(if $(CONFIG_OPENSSL_ENGINE),,out)-ssl-engine
ifeq ($(BUILD_VARIANT),with-pam)
CONFIGURE_ARGS += \
@@ -176,16 +178,6 @@ CONFIGURE_ARGS += \
--without-pam
endif
-ifeq ($(CONFIG_OPENSSL_ENGINE),y)
-CONFIGURE_ARGS+= \
- --with-ssl-engine
-endif
-
-ifneq ($(CONFIG_SSP_SUPPORT),y)
-CONFIGURE_ARGS += \
- --without-stackprotect
-endif
-
CONFIGURE_VARS += LD="$(TARGET_CC)"
ifeq ($(BUILD_VARIANT),with-pam)