aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/tor/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/net/tor/Makefile b/net/tor/Makefile
index 0bac41a3e..ee6e327cf 100644
--- a/net/tor/Makefile
+++ b/net/tor/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tor
PKG_VERSION:=0.4.3.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://dist.torproject.org/ \
@@ -103,18 +103,12 @@ CONFIGURE_ARGS += \
--disable-lzma \
--disable-zstd \
--with-tor-user=tor \
- --with-tor-group=tor
+ --with-tor-group=tor \
+ --with-pic
TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
TARGET_LDFLAGS += -Wl,--gc-sections -flto
-ifneq ($(CONFIG_SSP_SUPPORT),y)
- CONFIGURE_ARGS += \
- --disable-gcc-hardening
-else
- EXTRA_CFLAGS += $(FPIC)
-endif
-
CONFIGURE_VARS += \
CROSS_COMPILE="yes"