aboutsummaryrefslogtreecommitdiff
path: root/target/linux/qualcommax/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/qualcommax/Makefile')
-rw-r--r--target/linux/qualcommax/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/qualcommax/Makefile b/target/linux/qualcommax/Makefile
new file mode 100644
index 0000000000..c6b74e05c9
--- /dev/null
+++ b/target/linux/qualcommax/Makefile
@@ -0,0 +1,22 @@
+include $(TOPDIR)/rules.mk
+
+ARCH:=aarch64
+BOARD:=qualcommax
+BOARDNAME:=Qualcomm Atheros 802.11ax WiSoC-s
+FEATURES:=squashfs ramdisk fpu nand rtc emmc
+KERNELNAME:=Image dtbs
+CPU_TYPE:=cortex-a53
+SUBTARGETS:=generic
+
+KERNEL_PATCHVER:=6.1
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+ kmod-usb3 kmod-usb-dwc3 kmod-usb-dwc3-qcom \
+ kmod-leds-gpio kmod-gpio-button-hotplug \
+ kmod-phy-aquantia kmod-qca-nss-dp \
+ ath11k-firmware-ipq8074 kmod-ath11k-ahb \
+ wpad-basic-mbedtls uboot-envtools \
+ e2fsprogs kmod-fs-ext4 losetup
+
+$(eval $(call BuildTarget))