aboutsummaryrefslogtreecommitdiff
path: root/target/linux/qualcommax/Makefile
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-06-11 19:32:52 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-06-16 11:11:08 +0200
commitf02f6aaa8d4e1025ab4aa9f569123e57f689f4e5 (patch)
treea5cd6920cb495282ceaa8ddbbb4adf9297b8e2b4 /target/linux/qualcommax/Makefile
parentde9955a62f6aab6eafb2cfdffc4829ee97e69c04 (diff)
ipq807x: rename target to qualcommax
Currently, ipq807x only covers Qualcomm IPQ807x SoC-s. However, Qualcomm also has IPQ60xx and IPQ50xx SoC-s under the AX WiSoC-s and they share a lot of stuff with IPQ807x, especially IPQ60xx so to avoid duplicating kernel patches and everything lets make a common target with per SoC subtargets. Start doing that by renaming ipq807x to qualcommax so that dependencies on ipq807x target can be updated. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux/qualcommax/Makefile')
-rw-r--r--target/linux/qualcommax/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/qualcommax/Makefile b/target/linux/qualcommax/Makefile
new file mode 100644
index 0000000000..c6b74e05c9
--- /dev/null
+++ b/target/linux/qualcommax/Makefile
@@ -0,0 +1,22 @@
+include $(TOPDIR)/rules.mk
+
+ARCH:=aarch64
+BOARD:=qualcommax
+BOARDNAME:=Qualcomm Atheros 802.11ax WiSoC-s
+FEATURES:=squashfs ramdisk fpu nand rtc emmc
+KERNELNAME:=Image dtbs
+CPU_TYPE:=cortex-a53
+SUBTARGETS:=generic
+
+KERNEL_PATCHVER:=6.1
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+ kmod-usb3 kmod-usb-dwc3 kmod-usb-dwc3-qcom \
+ kmod-leds-gpio kmod-gpio-button-hotplug \
+ kmod-phy-aquantia kmod-qca-nss-dp \
+ ath11k-firmware-ipq8074 kmod-ath11k-ahb \
+ wpad-basic-mbedtls uboot-envtools \
+ e2fsprogs kmod-fs-ext4 losetup
+
+$(eval $(call BuildTarget))