aboutsummaryrefslogtreecommitdiff
path: root/target/linux/mediatek/image/filogic.mk
diff options
context:
space:
mode:
authorAllen Zhao <allenzhao@unielecinc.com>2024-03-09 10:44:58 +0800
committerDaniel Golle <daniel@makrotopia.org>2024-03-25 18:14:19 +0000
commit640b0b79ff05c42991e99a49ed81efb3fac25045 (patch)
tree28e9f92e75ec42f39c36eddc15dc0077d25ee05f /target/linux/mediatek/image/filogic.mk
parentff064b68d415ad425a156dc82735b5b66f109bd0 (diff)
mediatek: filogic: add Unielec U7981-01 support
Hardware specification: SoC: MediaTek MT7981B 2x A53 Flash: 8GB eMMC or 128 MB SPI-NAND RAM: 256MB Ethernet: 5x 10/100/1000 Mbps Switch: MediaTek MT7531AE WiFi: MediaTek MT7976C Button: Reset USB: M.2(B-key) for 4G/5G Module Power: DC 12V 1A UART: 3.3v, 115200n8 -------------------------- | Layout | | ----------------- | | 4 | VCC RX TX GND | <= | | ----------------- | -------------------------- The U-boot menu will automatically appear at startup, and then select the required options through UP/DOWN Key. NAND Flash and eMMC Flash instructions: 1. Set your computers IP adress to 192.168.1.2. 2. Run a TFTP server providing the sysupgrade.bin image. 3. Power on the router, into the U-Boot menu. 4. Select "2. Upgrade firmware" 5. Update sysupgrade.bin file name, input server IP and input device IP (if they deviate from the defaults) 6. Wait for automatic startup after burning Signed-off-by: Allen Zhao <allenzhao@unielecinc.com>
Diffstat (limited to 'target/linux/mediatek/image/filogic.mk')
-rw-r--r--target/linux/mediatek/image/filogic.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/filogic.mk b/target/linux/mediatek/image/filogic.mk
index 7d2fac56b6..e3b588c861 100644
--- a/target/linux/mediatek/image/filogic.mk
+++ b/target/linux/mediatek/image/filogic.mk
@@ -913,6 +913,28 @@ define Device/ubnt_unifi-6-plus
endef
TARGET_DEVICES += ubnt_unifi-6-plus
+define Device/unielec_u7981-01
+ DEVICE_VENDOR := Unielec
+ DEVICE_MODEL := U7981-01
+ DEVICE_DTS_DIR := ../dts
+ DEVICE_PACKAGES := kmod-mt7981-firmware mt7981-wo-firmware kmod-usb3 e2fsprogs f2fsck mkf2fs fdisk partx-utils
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+
+define Device/unielec_u7981-01-emmc
+ DEVICE_DTS := mt7981b-unielec-u7981-01-emmc
+ DEVICE_VARIANT := (EMMC)
+ $(call Device/unielec_u7981-01)
+endef
+TARGET_DEVICES += unielec_u7981-01-emmc
+
+define Device/unielec_u7981-01-nand
+ DEVICE_DTS := mt7981b-unielec-u7981-01-nand
+ DEVICE_VARIANT := (NAND)
+ $(call Device/unielec_u7981-01)
+endef
+TARGET_DEVICES += unielec_u7981-01-nand
+
define Device/xiaomi_mi-router-ax3000t
DEVICE_VENDOR := Xiaomi
DEVICE_MODEL := Mi Router AX3000T