aboutsummaryrefslogtreecommitdiff
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorDaniel Huici <danielhuici@hotmail.com>2024-02-04 23:59:48 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2024-02-27 22:27:46 +0100
commit9c24a14ffa779d9e69cbeef45c42403b781d94ca (patch)
treecdda0115e1f8f48595919742f2e7438dbc71f8ab /target/linux/lantiq/image
parentab853e157141cb92912c47177fff8d79b67b0724 (diff)
lantiq: add support for Arcadyan VRV9510KWAC23
The Arcadyan VRV9510KWAC23 (trade name Livebox Next) is a Lantiq router distributed by some spanish ISPs Hardware: - SoC: Lantiq VRX200 - CPU: 2x MIPS 34Kc 500 MHz - RAM: 256 MiB DDR2 - Flash: 128 MiB NAND - Ethernet: Built-in Gigabit Ethernet switch, 5x 1GbE - Wifi 2.4GHz: Broadcom BCM43222KFBG 802.11b/g/b MIMO 2T2R - Wifi 5GHz: Broadcom BCM4360KMLG 802.11ac MIMO 3T3R - USB: 2x USB 2.0 - DSL: Built-in VDSL/ADSL2+ XWAY VRX208 - LEDs: 8x - Buttons: 4x - Phone: Lantiq PEF 42068 V XWAY SLIC120 Install instructions: Detailed instructions can be found on the wiki https://openwrt.org/toh/arcadyan/vrv9510kwac23 1. Boot into UART mode and upload the the https://raw.githubusercontent.com/danielhuici/arcadyan-vrv9510kwac23-utils/main/u-boot.asc file via serial console to boot into U-Boot. 2. Perform a backup of the NAND 3. Setup a TFTP server and serve the https://github.com/danielhuici/arcadyan-vrv9510kwac23-utils/raw/main/u-boot.ltq.lzo.nandspl. Replace the OEM bootloader with this one. Erase your NAND and write the image into it 4. Reboot the router 5. Serve the OpenWrt ramdisk image on your TFTP server and boot it via U-Boot 6. When OpenWrt boots, flash the SquashFS OpenWrt image using LuCi interface, so OpenWrt gets installed into the NAND Signed-off-by: Daniel Huici <danielhuici@hotmail.com>
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/vr9.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/vr9.mk b/target/linux/lantiq/image/vr9.mk
index 53b05795aa..a9df6598d7 100644
--- a/target/linux/lantiq/image/vr9.mk
+++ b/target/linux/lantiq/image/vr9.mk
@@ -107,6 +107,21 @@ define Device/arcadyan_vgv7519-nor
endef
TARGET_DEVICES += arcadyan_vgv7519-nor
+define Device/arcadyan_vrv9510kwac23
+ $(Device/dsa-migration)
+ $(Device/NAND)
+ DEVICE_VENDOR := Arcadyan
+ DEVICE_MODEL := VRV9510KWAC23
+ DEVICE_ALT0_VENDOR := Livebox
+ DEVICE_ALT0_MODEL := Next
+ BOARD_NAME := VRV9510KWAC23
+ DEVICE_PACKAGES := kmod-b43 wpad-basic-mbedtls broadcom-43222-sprom \
+ broadcom-4360-sprom kmod-usb-dwc2 kmod-ltq-tapi kmod-ltq-vmmc
+ KERNEL_SIZE := 4096k
+ SUPPORTED_DEVICES += arcadyan_vrv9510kwac23
+endef
+TARGET_DEVICES += arcadyan_vrv9510kwac23
+
define Device/avm_fritz3370
$(Device/dsa-migration)
$(Device/AVM)