aboutsummaryrefslogtreecommitdiff
path: root/target/linux/apm821xx/modules.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2023-05-28 22:13:52 +0200
committerChristian Lamparter <chunkeey@gmail.com>2023-05-30 01:58:20 +0200
commit55fbcad20a2d9572966ddbb8856d3b01f68be23a (patch)
treef1924b9b7dfd2e859d0df3c32b957e8110b7f382 /target/linux/apm821xx/modules.mk
parentfd9dc10530ef04de58fd36947c03113345e9b949 (diff)
apm821xx: make crypto4xx as a standalone module
Make the crypto4xx crypto accelerator support as a standalone module. This saves 90kb on a gzipped kernel. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/modules.mk')
-rw-r--r--target/linux/apm821xx/modules.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/apm821xx/modules.mk b/target/linux/apm821xx/modules.mk
index 98610f9b2e..b837461157 100644
--- a/target/linux/apm821xx/modules.mk
+++ b/target/linux/apm821xx/modules.mk
@@ -11,3 +11,23 @@ define KernelPackage/ata-dwc/description
endef
$(eval $(call KernelPackage,ata-dwc))
+
+define KernelPackage/hw-crypto-4xx
+ TITLE:=Driver AMCC PPC4xx crypto accelerator
+ KCONFIG:= \
+ CONFIG_CRYPTO_HW=y \
+ CONFIG_HW_RANDOM=y \
+ CONFIG_CRYPTO_DEV_PPC4XX \
+ CONFIG_HW_RANDOM_PPC4XX=y
+ DEPENDS:=+kmod-random-core +kmod-crypto-manager \
+ +kmod-crypto-ccm +kmod-crypto-gcm \
+ +kmod-crypto-sha1 +kmod-crypto-sha256 +kmod-crypto-sha512
+ FILES:=$(LINUX_DIR)/drivers/crypto/amcc/crypto4xx.ko
+ AUTOLOAD:=$(call AutoLoad,09,sata_dwc_460ex,1)
+endef
+
+define KernelPackage/hw-crypto-4xx/description
+ Platform support for the on-chip crypto acceleration.
+endef
+
+$(eval $(call KernelPackage,hw-crypto-4xx))