aboutsummaryrefslogtreecommitdiff
path: root/target/linux/apm821xx/modules.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2023-05-28 21:22:52 +0200
committerChristian Lamparter <chunkeey@gmail.com>2023-05-30 01:58:20 +0200
commitfd9dc10530ef04de58fd36947c03113345e9b949 (patch)
tree920382ca449a8bf24c7d165e8c78c111114a941c /target/linux/apm821xx/modules.mk
parent88643360f8bfa3b6bce6764fa1e123278e1e5821 (diff)
apm821xx: make ata-dwc as a standalone module
In order to cut down on the Netgear WNDR4700, the ata driver can be outsourced. This helps other apm821xx devices too to save up on kernel size (~200 kb). Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/modules.mk')
-rw-r--r--target/linux/apm821xx/modules.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/apm821xx/modules.mk b/target/linux/apm821xx/modules.mk
new file mode 100644
index 0000000000..98610f9b2e
--- /dev/null
+++ b/target/linux/apm821xx/modules.mk
@@ -0,0 +1,13 @@
+define KernelPackage/ata-dwc
+ TITLE:=DesignWare Cores SATA support
+ KCONFIG:=CONFIG_SATA_DWC
+ FILES:=$(LINUX_DIR)/drivers/ata/sata_dwc_460ex.ko
+ AUTOLOAD:=$(call AutoLoad,40,sata_dwc_460ex,1)
+ $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-dwc/description
+ Platform support for the on-chip SATA controller.
+endef
+
+$(eval $(call KernelPackage,ata-dwc))