aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2018-05-10 15:23:30 +0200
committerToni Uhlig <matzeton@googlemail.com>2024-05-08 09:02:27 +0200
commit5c48e2503b5797600ea1209fc1f7077e87e483d7 (patch)
tree1088bb6579a32b11b1d50a2fd7ca3970241f04dc
parent52f32b65bd1d0d512fb2e7f89a53b32dc5769631 (diff)
udhcpc:
- drop capabilities before starting using capsh Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
-rw-r--r--package/network/config/netifd/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index d80c2eeed6..9d69cd9e18 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -30,6 +30,14 @@ define Package/netifd/conffiles
/etc/udhcpc.user.d/
endef
+define Package/netifd/config
+ config PACKAGE_netifd_capsh
+ bool
+ default 0
+ select CONFIG_PACKAGE_libcap-bin
+ prompt "Use capsh to drop capabilities"
+endef
+
TARGET_CFLAGS += \
-I$(STAGING_DIR)/usr/include/libnl-tiny \
-I$(STAGING_DIR)/usr/include