aboutsummaryrefslogtreecommitdiff
path: root/package/network/config/netifd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/config/netifd/Makefile')
-rw-r--r--package/network/config/netifd/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index d80c2eeed6..9d69cd9e18 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -30,6 +30,14 @@ define Package/netifd/conffiles
/etc/udhcpc.user.d/
endef
+define Package/netifd/config
+ config PACKAGE_netifd_capsh
+ bool
+ default 0
+ select CONFIG_PACKAGE_libcap-bin
+ prompt "Use capsh to drop capabilities"
+endef
+
TARGET_CFLAGS += \
-I$(STAGING_DIR)/usr/include/libnl-tiny \
-I$(STAGING_DIR)/usr/include