aboutsummaryrefslogtreecommitdiff
path: root/utils/zsh
diff options
context:
space:
mode:
Diffstat (limited to 'utils/zsh')
-rw-r--r--utils/zsh/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/utils/zsh/Makefile b/utils/zsh/Makefile
index 8a95c1511..9ab461df7 100644
--- a/utils/zsh/Makefile
+++ b/utils/zsh/Makefile
@@ -22,6 +22,7 @@ PKG_CPE_ID:=cpe:/a:zsh_project:zsh
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
+PKG_BUILD_FLAGS:=gc-sections
include $(INCLUDE_DIR)/package.mk
@@ -82,8 +83,8 @@ define Build/Configure
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" prep
endef
-TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections -flto
-TARGET_LDFLAGS += $(FPIC) -Wl,--gc-sections -flto
+TARGET_CFLAGS += $(FPIC) -flto
+TARGET_LDFLAGS += $(FPIC) -flto
define Package/zsh/postinst
#!/bin/sh