aboutsummaryrefslogtreecommitdiff
path: root/utils/zsh
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:09:13 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commit35f4ef76e0c88b690ec55f26aed072c4c5989eff (patch)
treec5b36bb3b16488c4546c3c283b8a6020e3966143 /utils/zsh
parent565866a47210c9711c29173052063779b6d3bcfc (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=gc-sections
See commit da370098 "treewide: add support for "gc-sections" in PKG_BUILD_FLAGS" on the main repository. Note: This only touches packages which use all three parts (-ffunction-sections, -fdata-sections and -Wl,--gc-sections) enabled by this build flag. Some packages only use a subset, and these are left unchanged for now. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'utils/zsh')
-rw-r--r--utils/zsh/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/utils/zsh/Makefile b/utils/zsh/Makefile
index 8a95c1511..9ab461df7 100644
--- a/utils/zsh/Makefile
+++ b/utils/zsh/Makefile
@@ -22,6 +22,7 @@ PKG_CPE_ID:=cpe:/a:zsh_project:zsh
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
+PKG_BUILD_FLAGS:=gc-sections
include $(INCLUDE_DIR)/package.mk
@@ -82,8 +83,8 @@ define Build/Configure
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" prep
endef
-TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections -flto
-TARGET_LDFLAGS += $(FPIC) -Wl,--gc-sections -flto
+TARGET_CFLAGS += $(FPIC) -flto
+TARGET_LDFLAGS += $(FPIC) -flto
define Package/zsh/postinst
#!/bin/sh