aboutsummaryrefslogtreecommitdiff
path: root/net/dnsdist
diff options
context:
space:
mode:
Diffstat (limited to 'net/dnsdist')
-rw-r--r--net/dnsdist/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net/dnsdist/Makefile b/net/dnsdist/Makefile
index b0d8f3c50..353b0d6fc 100644
--- a/net/dnsdist/Makefile
+++ b/net/dnsdist/Makefile
@@ -62,6 +62,12 @@ menu "Configuration"
help
"Enabled DNS over TLS Support for dnsdist"
default y
+
+ config DNSDIST_NET_SNMP
+ bool "Net-SNMP support"
+ help
+ "Enable Net-SNMP support for dnsdist"
+ default y
endmenu
endef
@@ -74,11 +80,11 @@ define Package/dnsdist
+DNSDIST_DNS_OVER_HTTPS:libh2o-evloop \
+DNSDIST_GNUTLS:libgnutls \
+DNSDIST_OPENSSL:libopenssl \
+ +DNSDIST_NET_SNMP:libnetsnmp \
+libatomic \
+libcap \
+libedit \
+libfstrm \
- +libnetsnmp \
+libsodium \
+lmdb \
+re2 \
@@ -110,7 +116,7 @@ CONFIGURE_ARGS+= \
--with-pic \
--with-re2 \
--with-lua=lua \
- --with-net-snmp \
+ $(if $(CONFIG_DNSDIST_NET_SNMP),--with,--without)-net-snmp \
$(if $(CONFIG_DNSDIST_GNUTLS),--with,--without)-gnutls \
$(if $(CONFIG_DNSDIST_OPENSSL),--with,--without)-libssl \
$(if $(CONFIG_DNSDIST_DNS_OVER_TLS),--enable-dns-over-tls,) \