aboutsummaryrefslogtreecommitdiff
path: root/net/dnsdist
diff options
context:
space:
mode:
authorPeter van Dijk <peter.van.dijk@powerdns.com>2021-04-22 17:57:25 +0200
committerPeter van Dijk <peter.van.dijk@powerdns.com>2021-05-28 23:24:11 +0200
commite8c8c5cce0d1fa9d49d4ec622ee1ed1c4c8c9cab (patch)
treee2bc1b6a42004ae5eebd95181f1e63027331a148 /net/dnsdist
parentb17cf4199dd92cc3d23f851858b1cea472340585 (diff)
dnsdist: make net-snmp support optional
Signed-off-by: Peter van Dijk <peter.van.dijk@powerdns.com>
Diffstat (limited to 'net/dnsdist')
-rw-r--r--net/dnsdist/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net/dnsdist/Makefile b/net/dnsdist/Makefile
index b0d8f3c50..353b0d6fc 100644
--- a/net/dnsdist/Makefile
+++ b/net/dnsdist/Makefile
@@ -62,6 +62,12 @@ menu "Configuration"
help
"Enabled DNS over TLS Support for dnsdist"
default y
+
+ config DNSDIST_NET_SNMP
+ bool "Net-SNMP support"
+ help
+ "Enable Net-SNMP support for dnsdist"
+ default y
endmenu
endef
@@ -74,11 +80,11 @@ define Package/dnsdist
+DNSDIST_DNS_OVER_HTTPS:libh2o-evloop \
+DNSDIST_GNUTLS:libgnutls \
+DNSDIST_OPENSSL:libopenssl \
+ +DNSDIST_NET_SNMP:libnetsnmp \
+libatomic \
+libcap \
+libedit \
+libfstrm \
- +libnetsnmp \
+libsodium \
+lmdb \
+re2 \
@@ -110,7 +116,7 @@ CONFIGURE_ARGS+= \
--with-pic \
--with-re2 \
--with-lua=lua \
- --with-net-snmp \
+ $(if $(CONFIG_DNSDIST_NET_SNMP),--with,--without)-net-snmp \
$(if $(CONFIG_DNSDIST_GNUTLS),--with,--without)-gnutls \
$(if $(CONFIG_DNSDIST_OPENSSL),--with,--without)-libssl \
$(if $(CONFIG_DNSDIST_DNS_OVER_TLS),--enable-dns-over-tls,) \