aboutsummaryrefslogtreecommitdiff
path: root/net/dnscrypt-proxy
diff options
context:
space:
mode:
Diffstat (limited to 'net/dnscrypt-proxy')
-rw-r--r--net/dnscrypt-proxy/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/net/dnscrypt-proxy/Makefile b/net/dnscrypt-proxy/Makefile
index 9d8883aab..060f9acda 100644
--- a/net/dnscrypt-proxy/Makefile
+++ b/net/dnscrypt-proxy/Makefile
@@ -23,6 +23,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
+PKG_BUILD_FLAGS:=gc-sections
PKG_CONFIG_DEPENDS:= \
CONFIG_DNSCRYPT_ENABLE_PLUGINS
@@ -84,12 +85,7 @@ define Build/Configure
endef
TARGET_CFLAGS += \
- -fomit-frame-pointer \
- -fdata-sections \
- -ffunction-sections
-
-TARGET_LDFLAGS += \
- -Wl,-gc-sections
+ -fomit-frame-pointer
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS)" \