aboutsummaryrefslogtreecommitdiff
path: root/net/dnscrypt-proxy
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:09:13 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commit35f4ef76e0c88b690ec55f26aed072c4c5989eff (patch)
treec5b36bb3b16488c4546c3c283b8a6020e3966143 /net/dnscrypt-proxy
parent565866a47210c9711c29173052063779b6d3bcfc (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=gc-sections
See commit da370098 "treewide: add support for "gc-sections" in PKG_BUILD_FLAGS" on the main repository. Note: This only touches packages which use all three parts (-ffunction-sections, -fdata-sections and -Wl,--gc-sections) enabled by this build flag. Some packages only use a subset, and these are left unchanged for now. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'net/dnscrypt-proxy')
-rw-r--r--net/dnscrypt-proxy/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/net/dnscrypt-proxy/Makefile b/net/dnscrypt-proxy/Makefile
index 9d8883aab..060f9acda 100644
--- a/net/dnscrypt-proxy/Makefile
+++ b/net/dnscrypt-proxy/Makefile
@@ -23,6 +23,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
+PKG_BUILD_FLAGS:=gc-sections
PKG_CONFIG_DEPENDS:= \
CONFIG_DNSCRYPT_ENABLE_PLUGINS
@@ -84,12 +85,7 @@ define Build/Configure
endef
TARGET_CFLAGS += \
- -fomit-frame-pointer \
- -fdata-sections \
- -ffunction-sections
-
-TARGET_LDFLAGS += \
- -Wl,-gc-sections
+ -fomit-frame-pointer
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS)" \