aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
Diffstat (limited to 'libs')
-rw-r--r--libs/oniguruma/Makefile2
-rw-r--r--libs/oniguruma/patches/0002-i_free_callout_name_entry.patch13
2 files changed, 14 insertions, 1 deletions
diff --git a/libs/oniguruma/Makefile b/libs/oniguruma/Makefile
index 6e88e5b7b..93088f02f 100644
--- a/libs/oniguruma/Makefile
+++ b/libs/oniguruma/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=oniguruma
PKG_VERSION:=6.9.5_rev1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=onig-v$(subst _,-,$(PKG_VERSION)).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/kkos/oniguruma/tar.gz/v$(PKG_VERSION)?
diff --git a/libs/oniguruma/patches/0002-i_free_callout_name_entry.patch b/libs/oniguruma/patches/0002-i_free_callout_name_entry.patch
new file mode 100644
index 000000000..f67a00cff
--- /dev/null
+++ b/libs/oniguruma/patches/0002-i_free_callout_name_entry.patch
@@ -0,0 +1,13 @@
+--- a/src/regparse.c 2020-04-26 09:20:56.000000000 +0200
++++ b/src/regparse.c 2020-06-14 21:22:18.396966276 +0200
+@@ -1294,7 +1294,9 @@
+ i_free_callout_name_entry(st_callout_name_key* key, CalloutNameEntry* e,
+ void* arg ARG_UNUSED)
+ {
+- xfree(e->name);
++ if (IS_NOT_NULL(e)) {
++ xfree(e->name);
++ }
+ /*xfree(key->s); */ /* is same as e->name */
+ xfree(key);
+ xfree(e);