aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2020-06-14 22:29:41 +0200
committerEneas U de Queiroz <cotequeiroz@gmail.com>2020-06-14 21:14:51 -0300
commitb4ddb635ea1693214d75a578b9d652a3388cc6d2 (patch)
tree6c5e7191198c901680866a8a20cf586a93ff92a8 /libs
parent74315625b917d14ed112be5c17c82d9d4f31419f (diff)
oniguruma: add patch to fix NULL pointer exception
I propose to carry this patch until a new upstream release includes it. For forther references see: https://github.com/openwrt/packages/issues/12403 and https://github.com/kkos/oniguruma/pull/196 Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'libs')
-rw-r--r--libs/oniguruma/Makefile2
-rw-r--r--libs/oniguruma/patches/0002-i_free_callout_name_entry.patch13
2 files changed, 14 insertions, 1 deletions
diff --git a/libs/oniguruma/Makefile b/libs/oniguruma/Makefile
index 6e88e5b7b..93088f02f 100644
--- a/libs/oniguruma/Makefile
+++ b/libs/oniguruma/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=oniguruma
PKG_VERSION:=6.9.5_rev1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=onig-v$(subst _,-,$(PKG_VERSION)).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/kkos/oniguruma/tar.gz/v$(PKG_VERSION)?
diff --git a/libs/oniguruma/patches/0002-i_free_callout_name_entry.patch b/libs/oniguruma/patches/0002-i_free_callout_name_entry.patch
new file mode 100644
index 000000000..f67a00cff
--- /dev/null
+++ b/libs/oniguruma/patches/0002-i_free_callout_name_entry.patch
@@ -0,0 +1,13 @@
+--- a/src/regparse.c 2020-04-26 09:20:56.000000000 +0200
++++ b/src/regparse.c 2020-06-14 21:22:18.396966276 +0200
+@@ -1294,7 +1294,9 @@
+ i_free_callout_name_entry(st_callout_name_key* key, CalloutNameEntry* e,
+ void* arg ARG_UNUSED)
+ {
+- xfree(e->name);
++ if (IS_NOT_NULL(e)) {
++ xfree(e->name);
++ }
+ /*xfree(key->s); */ /* is same as e->name */
+ xfree(key);
+ xfree(e);