aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
Diffstat (limited to 'libs')
-rw-r--r--libs/protobuf/Makefile1
-rw-r--r--libs/protobuf/patches/001-mipseb-compile.patch11
2 files changed, 12 insertions, 0 deletions
diff --git a/libs/protobuf/Makefile b/libs/protobuf/Makefile
index e5593c2a1..1553a7edc 100644
--- a/libs/protobuf/Makefile
+++ b/libs/protobuf/Makefile
@@ -16,6 +16,7 @@ PKG_SOURCE_URL:=http://protobuf.googlecode.com/files
PKG_MD5SUM:=a72001a9067a4c2c4e0e836d0f92ece4
PKG_BUILD_DEPENDS:=protobuf/host
+PKG_USE_MIPS16:=0
PKG_INSTALL:=1
diff --git a/libs/protobuf/patches/001-mipseb-compile.patch b/libs/protobuf/patches/001-mipseb-compile.patch
new file mode 100644
index 000000000..6eb059000
--- /dev/null
+++ b/libs/protobuf/patches/001-mipseb-compile.patch
@@ -0,0 +1,11 @@
+--- a/src/google/protobuf/stubs/platform_macros.h
++++ b/src/google/protobuf/stubs/platform_macros.h
+@@ -49,7 +49,7 @@
+ #elif defined(__ARMEL__)
+ #define GOOGLE_PROTOBUF_ARCH_ARM 1
+ #define GOOGLE_PROTOBUF_ARCH_32_BIT 1
+-#elif defined(__MIPSEL__)
++#elif defined(__MIPSEL__) || defined(__MIPSEB__)
+ #define GOOGLE_PROTOBUF_ARCH_MIPS 1
+ #define GOOGLE_PROTOBUF_ARCH_32_BIT 1
+ #elif defined(__pnacl__)