aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorEtienne CHAMPETIER <etienne.champetier@free.fr>2014-07-01 18:26:24 +0200
committerEtienne CHAMPETIER <etienne.champetier@free.fr>2014-07-01 18:36:53 +0200
commit92fc1687c1654aa06b30a48ead984578f6cc1e4e (patch)
treebbc63be16e91a73fde5cbe65334fceda096f9985 /libs
parentccda02e4fa237f2d75bd9685b171cd7bd1cabab5 (diff)
protobuf: make it compile with __MIPSEB__ (ar71xx)
it's only compile tested Signed-off-by: Etienne CHAMPETIER <etienne.champetier@free.fr>
Diffstat (limited to 'libs')
-rw-r--r--libs/protobuf/Makefile1
-rw-r--r--libs/protobuf/patches/001-mipseb-compile.patch11
2 files changed, 12 insertions, 0 deletions
diff --git a/libs/protobuf/Makefile b/libs/protobuf/Makefile
index e5593c2a1..1553a7edc 100644
--- a/libs/protobuf/Makefile
+++ b/libs/protobuf/Makefile
@@ -16,6 +16,7 @@ PKG_SOURCE_URL:=http://protobuf.googlecode.com/files
PKG_MD5SUM:=a72001a9067a4c2c4e0e836d0f92ece4
PKG_BUILD_DEPENDS:=protobuf/host
+PKG_USE_MIPS16:=0
PKG_INSTALL:=1
diff --git a/libs/protobuf/patches/001-mipseb-compile.patch b/libs/protobuf/patches/001-mipseb-compile.patch
new file mode 100644
index 000000000..6eb059000
--- /dev/null
+++ b/libs/protobuf/patches/001-mipseb-compile.patch
@@ -0,0 +1,11 @@
+--- a/src/google/protobuf/stubs/platform_macros.h
++++ b/src/google/protobuf/stubs/platform_macros.h
+@@ -49,7 +49,7 @@
+ #elif defined(__ARMEL__)
+ #define GOOGLE_PROTOBUF_ARCH_ARM 1
+ #define GOOGLE_PROTOBUF_ARCH_32_BIT 1
+-#elif defined(__MIPSEL__)
++#elif defined(__MIPSEL__) || defined(__MIPSEB__)
+ #define GOOGLE_PROTOBUF_ARCH_MIPS 1
+ #define GOOGLE_PROTOBUF_ARCH_32_BIT 1
+ #elif defined(__pnacl__)