aboutsummaryrefslogtreecommitdiff
path: root/libs/opus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'libs/opus/Makefile')
-rw-r--r--libs/opus/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/libs/opus/Makefile b/libs/opus/Makefile
index 9d74464b9..d23e9bbca 100644
--- a/libs/opus/Makefile
+++ b/libs/opus/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=opus
PKG_VERSION:=1.1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://downloads.xiph.org/releases/opus/
@@ -45,6 +45,12 @@ ifeq ($(CONFIG_SOFT_FLOAT),y)
--enable-fixed-point
endif
+CPU_ASM_BLACKLIST:=xscale arm926ej-s
+
+ifneq ($(findstring $(call qstrip,$(CONFIG_CPU_TYPE)),$(CPU_ASM_BLACKLIST)),)
+ CONFIGURE_ARGS+= --disable-asm
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/opus $(1)/usr/include/