aboutsummaryrefslogtreecommitdiff
path: root/libs/opus/Makefile
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2016-11-23 17:22:43 -0500
committerTed Hess <thess@kitschensync.net>2016-11-23 17:22:43 -0500
commit52d41ed0e36affae8a12b356cd3a9556fae00f84 (patch)
treecbc7d7dcdc8191d8e2fdb268335fdba57d3a7596 /libs/opus/Makefile
parent9637d4d02e7cf8724cbe2ad30cb9668f095e8d64 (diff)
opus: Disable ASM for xscale and arm926ej-s
Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'libs/opus/Makefile')
-rw-r--r--libs/opus/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/libs/opus/Makefile b/libs/opus/Makefile
index 9d74464b9..d23e9bbca 100644
--- a/libs/opus/Makefile
+++ b/libs/opus/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=opus
PKG_VERSION:=1.1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://downloads.xiph.org/releases/opus/
@@ -45,6 +45,12 @@ ifeq ($(CONFIG_SOFT_FLOAT),y)
--enable-fixed-point
endif
+CPU_ASM_BLACKLIST:=xscale arm926ej-s
+
+ifneq ($(findstring $(call qstrip,$(CONFIG_CPU_TYPE)),$(CPU_ASM_BLACKLIST)),)
+ CONFIGURE_ARGS+= --disable-asm
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/opus $(1)/usr/include/