aboutsummaryrefslogtreecommitdiff
path: root/libs/boost
diff options
context:
space:
mode:
Diffstat (limited to 'libs/boost')
-rw-r--r--libs/boost/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index b54ea1e84..ef0f31f02 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -226,16 +226,9 @@ define Build/InstallDev
$(1)/usr/include/boost/ \
# copies _all_ header files - independent of <--with-library>-argument above
- if [ -d $(PKG_INSTALL_DIR)/lib ]; then \
- $(INSTALL_DIR) \
- $(1)/usr/lib; \
- $(CP) \
- $(PKG_INSTALL_DIR)/lib/*.a \
- $(1)/usr/lib/; \
- $(CP) \
- $(PKG_INSTALL_DIR)/lib/*.so* \
- $(1)/usr/lib/; \
- fi
+ $(INSTALL_DIR) $(1)/usr/lib
+ -$(CP) $(PKG_INSTALL_DIR)/lib/*.a $(1)/usr/lib/
+ -$(CP) $(PKG_INSTALL_DIR)/lib/*.so* $(1)/usr/lib/
endef
define Host/Install