aboutsummaryrefslogtreecommitdiff
path: root/libs/boost
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-06-29 21:25:34 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2015-06-29 23:44:15 +0200
commitdd7b5a4240e7e1509d9626c585c69fc32c468d55 (patch)
tree9f2f3a2ad8571d65b3bd316c6154255698dc9883 /libs/boost
parentc31e6bb7c0ebbb20de636f2756aed221aefc2404 (diff)
boost: do not fail when no shared libs were build
When only boost is selected without any specific boost library no *.so file will be build and the InstallDev part is failing. Instead of checking if there is a lib directory just try to copy the libs and do not fail in case of an error. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'libs/boost')
-rw-r--r--libs/boost/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index b54ea1e84..ef0f31f02 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -226,16 +226,9 @@ define Build/InstallDev
$(1)/usr/include/boost/ \
# copies _all_ header files - independent of <--with-library>-argument above
- if [ -d $(PKG_INSTALL_DIR)/lib ]; then \
- $(INSTALL_DIR) \
- $(1)/usr/lib; \
- $(CP) \
- $(PKG_INSTALL_DIR)/lib/*.a \
- $(1)/usr/lib/; \
- $(CP) \
- $(PKG_INSTALL_DIR)/lib/*.so* \
- $(1)/usr/lib/; \
- fi
+ $(INSTALL_DIR) $(1)/usr/lib
+ -$(CP) $(PKG_INSTALL_DIR)/lib/*.a $(1)/usr/lib/
+ -$(CP) $(PKG_INSTALL_DIR)/lib/*.so* $(1)/usr/lib/
endef
define Host/Install