aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/python/files/python-package-ncurses.mk2
-rw-r--r--lang/python/patches/011-do-not-prefer-ncursesw.patch15
2 files changed, 16 insertions, 1 deletions
diff --git a/lang/python/files/python-package-ncurses.mk b/lang/python/files/python-package-ncurses.mk
index 04751ef83..bab941559 100644
--- a/lang/python/files/python-package-ncurses.mk
+++ b/lang/python/files/python-package-ncurses.mk
@@ -8,7 +8,7 @@
define Package/python-ncurses
$(call Package/python/Default)
TITLE:=Python $(PYTHON_VERSION) ncurses module
- DEPENDS:=+python-light +libncursesw
+ DEPENDS:=+python-light +libncurses
endef
$(eval $(call PyBasePackage,python-ncurses, \
diff --git a/lang/python/patches/011-do-not-prefer-ncursesw.patch b/lang/python/patches/011-do-not-prefer-ncursesw.patch
new file mode 100644
index 000000000..c5f323c43
--- /dev/null
+++ b/lang/python/patches/011-do-not-prefer-ncursesw.patch
@@ -0,0 +1,15 @@
+diff --git a/setup.py b/setup.py
+index 7868b7b..86b0119 100644
+--- a/setup.py
++++ b/setup.py
+@@ -725,8 +725,8 @@ class PyBuildExt(build_ext):
+ # use the same library for the readline and curses modules.
+ if 'curses' in readline_termcap_library:
+ curses_library = readline_termcap_library
+- elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
+- curses_library = 'ncursesw'
++ #elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
++ # curses_library = 'ncursesw'
+ elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
+ curses_library = 'ncurses'
+ elif self.compiler.find_library_file(lib_dirs, 'curses'):