aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-04-21 21:31:48 +0200
committerSteven Barth <steven@midlink.org>2015-04-21 21:31:48 +0200
commit14f680ea3beb79a7c219585c1a18ab1a85debc81 (patch)
tree9724a6e30edf8e4fc2fcd9703e44fb5513702c9b
parent18b47920336409ee21a4c46ac47acfb71c473755 (diff)
parent1dc93065588c043d74648266fed46b39085549fb (diff)
Merge pull request #1158 from commodo/python-ncurses
python: force libncurses
-rw-r--r--lang/python/files/python-package-ncurses.mk2
-rw-r--r--lang/python/patches/011-do-not-prefer-ncursesw.patch15
2 files changed, 16 insertions, 1 deletions
diff --git a/lang/python/files/python-package-ncurses.mk b/lang/python/files/python-package-ncurses.mk
index 04751ef83..bab941559 100644
--- a/lang/python/files/python-package-ncurses.mk
+++ b/lang/python/files/python-package-ncurses.mk
@@ -8,7 +8,7 @@
define Package/python-ncurses
$(call Package/python/Default)
TITLE:=Python $(PYTHON_VERSION) ncurses module
- DEPENDS:=+python-light +libncursesw
+ DEPENDS:=+python-light +libncurses
endef
$(eval $(call PyBasePackage,python-ncurses, \
diff --git a/lang/python/patches/011-do-not-prefer-ncursesw.patch b/lang/python/patches/011-do-not-prefer-ncursesw.patch
new file mode 100644
index 000000000..c5f323c43
--- /dev/null
+++ b/lang/python/patches/011-do-not-prefer-ncursesw.patch
@@ -0,0 +1,15 @@
+diff --git a/setup.py b/setup.py
+index 7868b7b..86b0119 100644
+--- a/setup.py
++++ b/setup.py
+@@ -725,8 +725,8 @@ class PyBuildExt(build_ext):
+ # use the same library for the readline and curses modules.
+ if 'curses' in readline_termcap_library:
+ curses_library = readline_termcap_library
+- elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
+- curses_library = 'ncursesw'
++ #elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
++ # curses_library = 'ncursesw'
+ elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
+ curses_library = 'ncurses'
+ elif self.compiler.find_library_file(lib_dirs, 'curses'):