aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorPaul Spooren <spooren@informatik.uni-leipzig.de>2018-04-21 21:20:54 +0900
committerPaul Spooren <spooren@informatik.uni-leipzig.de>2018-04-21 21:24:06 +0900
commitad05349db67300ed67de4927f2abd7bfe531fd80 (patch)
treea766f13b84936d974555de4e598b52ea1960904d /utils
parentedd002dc3f6528c6dda394adc4be26969e6add65 (diff)
bmx7-dnsupdate: wait 10 secs if bmx7 ins't running
If bmx7 isn't running just yet the folder `/var/run/bmx7/json/originators` is missing and so the while loop runs non stop. Now the loop sleeps for 10 seconds if inotifywait fails. Signed-off-by: Paul Spooren <spooren@informatik.uni-leipzig.de>
Diffstat (limited to 'utils')
-rw-r--r--utils/bmx7-dnsupdate/Makefile2
-rwxr-xr-xutils/bmx7-dnsupdate/files/usr/bin/bmx7-dnsupdate2
2 files changed, 2 insertions, 2 deletions
diff --git a/utils/bmx7-dnsupdate/Makefile b/utils/bmx7-dnsupdate/Makefile
index c9c024ba0..1573d257d 100644
--- a/utils/bmx7-dnsupdate/Makefile
+++ b/utils/bmx7-dnsupdate/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=bmx7-dnsupdate
PKG_VERSION:=0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
include $(INCLUDE_DIR)/package.mk
diff --git a/utils/bmx7-dnsupdate/files/usr/bin/bmx7-dnsupdate b/utils/bmx7-dnsupdate/files/usr/bin/bmx7-dnsupdate
index 3433fe742..2f87437a2 100755
--- a/utils/bmx7-dnsupdate/files/usr/bin/bmx7-dnsupdate
+++ b/utils/bmx7-dnsupdate/files/usr/bin/bmx7-dnsupdate
@@ -25,5 +25,5 @@ while true; do
killall -HUP dnsmasq
# block until originators changes
- inotifywait -e create -e delete -q /var/run/bmx7/json/originators/
+ inotifywait -e create -e delete -q /var/run/bmx7/json/originators/ || sleep 10
done