aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorDaniel Golle <dangowrt@users.noreply.github.com>2018-04-28 13:08:02 +0200
committerGitHub <noreply@github.com>2018-04-28 13:08:02 +0200
commit9859871c03753d70ca1031036104ee17d7d9c265 (patch)
tree17fcafb3a5b067278e57ad950f5d0cdde0fe7ba2 /utils
parent916b2f7cb7d61172f0add7352e4dfb57e5c095b8 (diff)
parentad05349db67300ed67de4927f2abd7bfe531fd80 (diff)
Merge pull request #5945 from aparcar/inotify-fixup
bmx7-dnsupdate: wait 10 secs if bmx7 ins't running
Diffstat (limited to 'utils')
-rw-r--r--utils/bmx7-dnsupdate/Makefile2
-rwxr-xr-xutils/bmx7-dnsupdate/files/usr/bin/bmx7-dnsupdate2
2 files changed, 2 insertions, 2 deletions
diff --git a/utils/bmx7-dnsupdate/Makefile b/utils/bmx7-dnsupdate/Makefile
index c9c024ba0..1573d257d 100644
--- a/utils/bmx7-dnsupdate/Makefile
+++ b/utils/bmx7-dnsupdate/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=bmx7-dnsupdate
PKG_VERSION:=0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
include $(INCLUDE_DIR)/package.mk
diff --git a/utils/bmx7-dnsupdate/files/usr/bin/bmx7-dnsupdate b/utils/bmx7-dnsupdate/files/usr/bin/bmx7-dnsupdate
index 3433fe742..2f87437a2 100755
--- a/utils/bmx7-dnsupdate/files/usr/bin/bmx7-dnsupdate
+++ b/utils/bmx7-dnsupdate/files/usr/bin/bmx7-dnsupdate
@@ -25,5 +25,5 @@ while true; do
killall -HUP dnsmasq
# block until originators changes
- inotifywait -e create -e delete -q /var/run/bmx7/json/originators/
+ inotifywait -e create -e delete -q /var/run/bmx7/json/originators/ || sleep 10
done