aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-27 17:30:01 -0800
committerRosen Penev <rosenp@gmail.com>2019-11-27 23:40:40 -0800
commit9059e586d7be624619190a748a7d008044adc00a (patch)
tree7ee595a177324d32eb5c2ecb780b2540b8a06ffa /utils
parent5256c104e831f477f336646dadbe80fb4488faa1 (diff)
evtest: Fix compilation with musl
Backported upstream patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/evtest/Makefile2
-rw-r--r--utils/evtest/patches/010-musl.patch24
2 files changed, 25 insertions, 1 deletions
diff --git a/utils/evtest/Makefile b/utils/evtest/Makefile
index ed5e03d52..0bd9a4754 100644
--- a/utils/evtest/Makefile
+++ b/utils/evtest/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=evtest
PKG_VERSION:=1.34
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://cgit.freedesktop.org/evtest/snapshot
diff --git a/utils/evtest/patches/010-musl.patch b/utils/evtest/patches/010-musl.patch
new file mode 100644
index 000000000..92260297c
--- /dev/null
+++ b/utils/evtest/patches/010-musl.patch
@@ -0,0 +1,24 @@
+From 12d5ea5ca2d9a47a1cab06caf2b36967667a3daf Mon Sep 17 00:00:00 2001
+From: Leo <thinkabit.ukim@gmail.com>
+Date: Sun, 24 Nov 2019 20:58:20 +0100
+Subject: [PATCH] Add missing include of limits.h for PATH_MAX
+
+---
+ evtest.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/evtest.c b/evtest.c
+index 548c203..be5e42c 100644
+--- a/evtest.c
++++ b/evtest.c
+@@ -59,6 +59,7 @@
+ #include <sys/time.h>
+ #include <sys/types.h>
+ #include <unistd.h>
++#include <limits.h> /* PATH_MAX */
+
+ #define BITS_PER_LONG (sizeof(long) * 8)
+ #define NBITS(x) ((((x)-1)/BITS_PER_LONG)+1)
+--
+2.22.0
+