aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-27 23:22:47 -0800
committerRosen Penev <rosenp@gmail.com>2019-11-27 23:30:09 -0800
commit5256c104e831f477f336646dadbe80fb4488faa1 (patch)
treef555cc4bc1cc2a2647deca40b46db4ea63130bfa /utils
parent1b2e94e537e901b989727514f591be8140718f88 (diff)
pciutils: Fix pkgconfig file
It's pointing to the host. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/mt-st/patches/010-sysmacros.patch20
-rw-r--r--utils/pciutils/Makefile4
2 files changed, 20 insertions, 4 deletions
diff --git a/utils/mt-st/patches/010-sysmacros.patch b/utils/mt-st/patches/010-sysmacros.patch
index 8e4b37378..456b2a752 100644
--- a/utils/mt-st/patches/010-sysmacros.patch
+++ b/utils/mt-st/patches/010-sysmacros.patch
@@ -1,10 +1,24 @@
+diff --git a/mt.c b/mt.c
+index d4058c0..4837808 100644
--- a/mt.c
+++ b/mt.c
-@@ -21,6 +21,7 @@
+@@ -20,6 +20,7 @@
+ #include <fcntl.h>
#include <sys/types.h>
#include <sys/ioctl.h>
- #include <sys/stat.h>
+#include <sys/sysmacros.h>
+ #include <sys/stat.h>
#include <sys/utsname.h>
- #include "mtio.h"
+diff --git a/stinit.c b/stinit.c
+index 5a50341..af5582c 100644
+--- a/stinit.c
++++ b/stinit.c
+@@ -16,6 +16,7 @@
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <dirent.h>
++#include <limits.h>
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>
+ #include <sys/sysmacros.h>
diff --git a/utils/pciutils/Makefile b/utils/pciutils/Makefile
index ed287eeff..52bc1f1e3 100644
--- a/utils/pciutils/Makefile
+++ b/utils/pciutils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pciutils
PKG_VERSION:=3.6.2
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
@@ -83,6 +83,8 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_BUILD_DIR)/lib/libpci.pc $(1)/usr/lib/pkgconfig
+ $(SED) 's,/usr/include,$$$${prefix}/include,g' $(1)/usr/lib/pkgconfig/libpci.pc
+ $(SED) 's,/usr/lib,$$$${prefix}/lib,g' $(1)/usr/lib/pkgconfig/libpci.pc
$(INSTALL_DIR) $(1)/usr/include/pci
$(CP) $(foreach i,pci.h config.h header.h types.h, \
$(PKG_BUILD_DIR)/lib/$(i)) $(1)/usr/include/pci