aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-08-04 15:33:34 -0700
committerGitHub <noreply@github.com>2019-08-04 15:33:34 -0700
commit55567b850a509cac3f4488eae7696567776d95d6 (patch)
treea08e74151e75a92f9fa13e7ff2ea3d9d54087dc9 /utils
parent31977ae6f3cdb26908e4dad309cff434d0ed808f (diff)
parent8ca5cf042d6e08f1e7b9f86cb8338d2982a9d296 (diff)
Merge pull request #9633 from neheb/fin
findutils: Add missing header
Diffstat (limited to 'utils')
-rw-r--r--utils/findutils/Makefile9
-rw-r--r--utils/findutils/patches/010-sysmacros.patch11
2 files changed, 16 insertions, 4 deletions
diff --git a/utils/findutils/Makefile b/utils/findutils/Makefile
index 2463fc6ee..74861029d 100644
--- a/utils/findutils/Makefile
+++ b/utils/findutils/Makefile
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2006-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -8,14 +8,15 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=findutils
PKG_VERSION:=4.6.0
-PKG_RELEASE:=3
-
-PKG_LICENSE:=GPL-3.0+
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
PKG_HASH:=ded4c9f73731cd48fec3b6bdaccce896473b6d8e337e9612e16cf1431bb1169d
+
PKG_MAINTAINER:=Daniel Dickinson <cshored@thecshore.com>
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=COPYING
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
diff --git a/utils/findutils/patches/010-sysmacros.patch b/utils/findutils/patches/010-sysmacros.patch
new file mode 100644
index 000000000..dc3678d0a
--- /dev/null
+++ b/utils/findutils/patches/010-sysmacros.patch
@@ -0,0 +1,11 @@
+--- a/gl/lib/mountlist.c
++++ b/gl/lib/mountlist.c
+@@ -33,6 +33,8 @@
+
+ #include <unistd.h>
+
++#include <sys/sysmacros.h>
++
+ #if HAVE_SYS_PARAM_H
+ # include <sys/param.h>
+ #endif