aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-08-04 14:47:06 -0700
committerRosen Penev <rosenp@gmail.com>2019-08-04 14:47:06 -0700
commit8ca5cf042d6e08f1e7b9f86cb8338d2982a9d296 (patch)
treeab9b9998f654432b3c761b2dd4dd56be778eda29 /utils
parentfca20e2b2fdf4a83db8e2c7904225422b11f0d2e (diff)
findutils: Add missing header
New version of musl no longer internally includes this header. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/findutils/Makefile2
-rw-r--r--utils/findutils/patches/010-sysmacros.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/utils/findutils/Makefile b/utils/findutils/Makefile
index 9293f453b..74861029d 100644
--- a/utils/findutils/Makefile
+++ b/utils/findutils/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=findutils
PKG_VERSION:=4.6.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
diff --git a/utils/findutils/patches/010-sysmacros.patch b/utils/findutils/patches/010-sysmacros.patch
new file mode 100644
index 000000000..dc3678d0a
--- /dev/null
+++ b/utils/findutils/patches/010-sysmacros.patch
@@ -0,0 +1,11 @@
+--- a/gl/lib/mountlist.c
++++ b/gl/lib/mountlist.c
+@@ -33,6 +33,8 @@
+
+ #include <unistd.h>
+
++#include <sys/sysmacros.h>
++
+ #if HAVE_SYS_PARAM_H
+ # include <sys/param.h>
+ #endif