aboutsummaryrefslogtreecommitdiff
path: root/utils/zsh
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:27:01 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commite7d9c865036d7bc2ac30604e8573f25ae601aed1 (patch)
tree5efb8a25df387e8e79356447c648ecc3306176b3 /utils/zsh
parent35f4ef76e0c88b690ec55f26aed072c4c5989eff (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=lto
See commit 07730ff3 "treewide: add support for "lto" in PKG_BUILD_FLAGS" on the main repository. Note: Some packages only added `-flto` to CFLAGS and not LDFLAGS. This fixes it and properly enables LTO. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'utils/zsh')
-rw-r--r--utils/zsh/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/utils/zsh/Makefile b/utils/zsh/Makefile
index 9ab461df7..6fc713a5d 100644
--- a/utils/zsh/Makefile
+++ b/utils/zsh/Makefile
@@ -22,7 +22,7 @@ PKG_CPE_ID:=cpe:/a:zsh_project:zsh
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
-PKG_BUILD_FLAGS:=gc-sections
+PKG_BUILD_FLAGS:=gc-sections lto
include $(INCLUDE_DIR)/package.mk
@@ -83,8 +83,8 @@ define Build/Configure
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" prep
endef
-TARGET_CFLAGS += $(FPIC) -flto
-TARGET_LDFLAGS += $(FPIC) -flto
+TARGET_CFLAGS += $(FPIC)
+TARGET_LDFLAGS += $(FPIC)
define Package/zsh/postinst
#!/bin/sh