aboutsummaryrefslogtreecommitdiff
path: root/utils/zsh
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-12-19 10:32:25 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-12-19 10:35:33 +0100
commitc09d6042fe3b58d7eb0fdc65fc9968c47d98aea1 (patch)
tree05f5188eef53f0887d1de7dde5a1a8fa37d7184c /utils/zsh
parentd2d193d81885cd2351e3bd53f6f4cc8ec092e26d (diff)
zsh: drop bash syntax in postinst
Signed-off-by: Karel Kočí <karel.koci@nic.cz>
Diffstat (limited to 'utils/zsh')
-rw-r--r--utils/zsh/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/utils/zsh/Makefile b/utils/zsh/Makefile
index 85b441f9f..a2e37ca1f 100644
--- a/utils/zsh/Makefile
+++ b/utils/zsh/Makefile
@@ -92,7 +92,7 @@ grep zsh $${IPKG_INSTROOT}/etc/shells || \
echo "/usr/bin/zsh" >> $${IPKG_INSTROOT}/etc/shells
# Backwards compatibility
-if [[ -e /bin/zsh ]] && ([[ ! -L /bin/zsh ]] || [[ "$(readlink -fn $${IPKG_INSTROOT}/bin/zsh)" != "../$(CONFIGURE_PREFIX)/bin/zsh" ]]); then
+if [ -e /bin/zsh ] && { [ ! -L /bin/zsh ] || [ "$(readlink -fn $${IPKG_INSTROOT}/bin/zsh)" != "../$(CONFIGURE_PREFIX)/bin/zsh" ]; }; then
ln -fs "../$(CONFIGURE_PREFIX)/bin/zsh" "$${IPKG_INSTROOT}/bin/zsh"
fi
endef