aboutsummaryrefslogtreecommitdiff
path: root/utils/zsh
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-12-18 09:57:23 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-12-18 10:04:41 +0100
commitd2d193d81885cd2351e3bd53f6f4cc8ec092e26d (patch)
treea607376895c563a6481e262870f44fc8dd2c9f92 /utils/zsh
parentb1634c1737bb016f602a13802faba08570b9cb70 (diff)
zsh: fix invalid postrm script and little refactor of scripts
The postrm script was missing shebang. Postrm scripts are packaged and executed directly and not sourced by default script (as in case of prerm and postinst). Also move some indents around to not confuse reader. The section in postinst was indented to same level as grep "condition" but is on same level as initial grep (not part of that "condition"). Signed-off-by: Karel Kočí <karel.koci@nic.cz>
Diffstat (limited to 'utils/zsh')
-rw-r--r--utils/zsh/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/utils/zsh/Makefile b/utils/zsh/Makefile
index b3f96d2ac..85b441f9f 100644
--- a/utils/zsh/Makefile
+++ b/utils/zsh/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=zsh
PKG_VERSION:=5.6.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/zsh
@@ -91,10 +91,10 @@ define Package/zsh/postinst
grep zsh $${IPKG_INSTROOT}/etc/shells || \
echo "/usr/bin/zsh" >> $${IPKG_INSTROOT}/etc/shells
- # Backwards compatibility
- if [[ -e /bin/zsh ]] && ([[ ! -L /bin/zsh ]] || [[ "$(readlink -fn $${IPKG_INSTROOT}/bin/zsh)" != "../$(CONFIGURE_PREFIX)/bin/zsh" ]]); then
- ln -fs "../$(CONFIGURE_PREFIX)/bin/zsh" "$${IPKG_INSTROOT}/bin/zsh"
- fi
+# Backwards compatibility
+if [[ -e /bin/zsh ]] && ([[ ! -L /bin/zsh ]] || [[ "$(readlink -fn $${IPKG_INSTROOT}/bin/zsh)" != "../$(CONFIGURE_PREFIX)/bin/zsh" ]]); then
+ ln -fs "../$(CONFIGURE_PREFIX)/bin/zsh" "$${IPKG_INSTROOT}/bin/zsh"
+fi
endef
define Package/zsh/install
@@ -107,7 +107,8 @@ define Package/zsh/install
endef
define Package/zsh/postrm
- rm -rf "$${IPKG_INSTROOT}/$(CONFIGURE_PREFIX)/share/zsh/$(PKG_VERSION)"
+#!/bin/sh
+rm -rf "$${IPKG_INSTROOT}/$(CONFIGURE_PREFIX)/share/zsh/$(PKG_VERSION)"
endef
$(eval $(call BuildPackage,zsh))