aboutsummaryrefslogtreecommitdiff
path: root/utils/sockread
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-01-29 19:51:31 -0800
committerRosen Penev <rosenp@gmail.com>2022-01-31 07:05:17 -0800
commitc61bad460e079ee0ee31a4dc09708e015a47e087 (patch)
tree947c0f2631d54706e09f78337a52b10b7b238952 /utils/sockread
parent31a8112c51347ba4af5ddcfbea0cbf5a96825617 (diff)
sockread: add missing header
Needed for memset, memcpy, and strerror. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/sockread')
-rw-r--r--utils/sockread/Makefile2
-rw-r--r--utils/sockread/src/main.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/utils/sockread/Makefile b/utils/sockread/Makefile
index d3c15d468..52daf82b1 100644
--- a/utils/sockread/Makefile
+++ b/utils/sockread/Makefile
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=sockread
PKG_VERSION:=1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=CC0-1.0
include $(INCLUDE_DIR)/package.mk
diff --git a/utils/sockread/src/main.c b/utils/sockread/src/main.c
index 06c21def4..c685bce71 100644
--- a/utils/sockread/src/main.c
+++ b/utils/sockread/src/main.c
@@ -1,4 +1,4 @@
-
+#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#include <errno.h>