aboutsummaryrefslogtreecommitdiff
path: root/utils/sane-backends/Makefile
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2020-11-20 20:39:40 -0300
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>2020-11-22 02:11:09 -0300
commitc40d882587c0d37c86cd753176b57e1ae29837a8 (patch)
treefaaf44b05f5e93b9c860de7de82f5c02368cb0cf /utils/sane-backends/Makefile
parent2e4fe76be43f28adc0b39c5f9ba1f020bcd55753 (diff)
sabe-backends: update to 1.0.31
* adds the canon_lide70 backend * avision: adds support for the KODAK i1120, fixes thread cancellation issues, disables exposure option for non-filmscanners * canon_dr: improves error reporting * dmc: fixes compiler warnings on the scan area options * epsonds: rewrites the network I/O following changes made to the * epson2 backend in 1.0.30 to fix security issues. Network support is still unsupported. * fujitsu: adds support for the fi-800R and a card scanning slot, fixes a bug when reading hardware sensors on the first invocation. Adds USB IDs for fi-7800 and fi-7900. * genesys: adds support for the Canon 5600F, Canon LiDE 90, Plustek OpticFilm 7200 and 7200 (v2), 7400, 7600i, 8100 and 8200i. Fixes several issues with the Canon 8600F. Adds 4800dpi support for the Canon LiDE 210 and fixes 3200dpi flatbed support on the Canon 8400F. Adds an option to fill dark calibration with a constant. Adds transparency support for gl847 chipset based devices. Fixes CIS scanner support for gl842 chipset based devices. Removes lineart and image enhancement emulation support. * gphoto: supports the PLANon DocuPen RC800 (with a recent enough version of gphoto2) * gt68xx: modifies scan cancellation behaviour * hp5400: adds button support, fixes a scan cancellation crash issue * pixma: add supports for the i-SENSYS MF440 Series and untested support for the PIXMMA G7000 Series and GM4000 Series as well as the i-SENSYS MF720 Series. * plustek: fixes a potential buffer overrun * test: adds gamma options Patches: - ADD: 102-pixma_Restore_old_behaviour_in_case_XML_support_is_missing.patch: pixma was failing to detect libxml2, even when it exists (https://gitlab.com/sane-project/backends/-/issues/345) - DROP: 100-fix-bigendian.patch: fix in release Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Diffstat (limited to 'utils/sane-backends/Makefile')
-rw-r--r--utils/sane-backends/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/utils/sane-backends/Makefile b/utils/sane-backends/Makefile
index 4783eff8f..df94f7733 100644
--- a/utils/sane-backends/Makefile
+++ b/utils/sane-backends/Makefile
@@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sane-backends
-PKG_VERSION:=1.0.30
-PKG_RELEASE:=2
+PKG_VERSION:=1.0.31
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://gitlab.com/sane-project/backends/uploads/c3dd60c9e054b5dee1e7b01a7edc98b0
-PKG_HASH:=3f5d96a9c47f6124a46bb577c776bbc4896dd17b9203d8bfbc7fe8cbbcf279a3
+PKG_SOURCE_URL:=https://gitlab.com/sane-project/backends/uploads/8bf1cae2e1803aefab9e5331550e5d5d/
+PKG_HASH:=4a3b10fcb398ed854777d979498645edfe66fcac2f2fd2b9117a79ff45e2a5aa
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
PKG_LICENSE:=GPL-2.0 GPL-2.0-or-later
@@ -179,7 +179,7 @@ CONFIGURE_ARGS += \
--enable-static \
--disable-preload \
--without-snmp \
- --disable-avahi \
+ --without-avahi \
--disable-locking \
--without-usb-record-replay \
@@ -312,6 +312,7 @@ $(eval $(call SaneBackend,canon630u,the Canon 630u USB flatbed scanner,+libusb-1
$(eval $(call SaneBackend,canon_dr,Canon DR-series scanners,+libusb-1.0))
# Depends on libieee1284
#$(eval $(call SaneBackend,canon_pp,Canon CanoScan Parallel Port flatbed scanners,+libieee1284))
+$(eval $(call SaneBackend,canon_lide70,Canon LiDE 70 USB flatbed scanner,))
$(eval $(call SaneBackend,cardscan,Corex CardScan usb scanners,+libusb-1.0))
$(eval $(call SaneBackend,coolscan,Nikon film-scanners,+libusb-1.0))
$(eval $(call SaneBackend,coolscan2,Nikon Coolscan film scanners,+libusb-1.0))
@@ -327,7 +328,7 @@ $(eval $(call SaneBackend,epsonds,EPSON scanners,+libjpeg +libusb-1.0)) ####
$(eval $(call SaneBackend,epson2,EPSON scanners,+libusb-1.0))
#$(eval $(call SaneBackend,escl,AirScan/eSCL devices,+libcurl +libxml2 +libnetsnmp +libavahi))
$(eval $(call SaneBackend,fujitsu,Fujitsu flatbed and ADF scanners,+libusb-1.0))
-$(eval $(call SaneBackend,genesys,GL646 GL841 GL843 GL847 and GL124 based USB flatbed scanners,+libstdcpp +libusb-1.0))
+$(eval $(call SaneBackend,genesys,GL646 GL841 GL843 GL847 and GL124 based USB flatbed scanners,+libstdcpp +libusb-1.0 +libtiff))
$(eval $(call SaneBackend,gphoto2,digital cameras supported by gphoto2,+libjpeg +libgphoto2))
$(eval $(call SaneBackend,gt68xx,GT-68XX based USB flatbed scanners,+libusb-1.0))
$(eval $(call SaneBackend,hp,HP ScanJet scanners,+libusb-1.0))