aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2020-11-20 20:39:40 -0300
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>2020-11-22 02:11:09 -0300
commitc40d882587c0d37c86cd753176b57e1ae29837a8 (patch)
treefaaf44b05f5e93b9c860de7de82f5c02368cb0cf
parent2e4fe76be43f28adc0b39c5f9ba1f020bcd55753 (diff)
sabe-backends: update to 1.0.31
* adds the canon_lide70 backend * avision: adds support for the KODAK i1120, fixes thread cancellation issues, disables exposure option for non-filmscanners * canon_dr: improves error reporting * dmc: fixes compiler warnings on the scan area options * epsonds: rewrites the network I/O following changes made to the * epson2 backend in 1.0.30 to fix security issues. Network support is still unsupported. * fujitsu: adds support for the fi-800R and a card scanning slot, fixes a bug when reading hardware sensors on the first invocation. Adds USB IDs for fi-7800 and fi-7900. * genesys: adds support for the Canon 5600F, Canon LiDE 90, Plustek OpticFilm 7200 and 7200 (v2), 7400, 7600i, 8100 and 8200i. Fixes several issues with the Canon 8600F. Adds 4800dpi support for the Canon LiDE 210 and fixes 3200dpi flatbed support on the Canon 8400F. Adds an option to fill dark calibration with a constant. Adds transparency support for gl847 chipset based devices. Fixes CIS scanner support for gl842 chipset based devices. Removes lineart and image enhancement emulation support. * gphoto: supports the PLANon DocuPen RC800 (with a recent enough version of gphoto2) * gt68xx: modifies scan cancellation behaviour * hp5400: adds button support, fixes a scan cancellation crash issue * pixma: add supports for the i-SENSYS MF440 Series and untested support for the PIXMMA G7000 Series and GM4000 Series as well as the i-SENSYS MF720 Series. * plustek: fixes a potential buffer overrun * test: adds gamma options Patches: - ADD: 102-pixma_Restore_old_behaviour_in_case_XML_support_is_missing.patch: pixma was failing to detect libxml2, even when it exists (https://gitlab.com/sane-project/backends/-/issues/345) - DROP: 100-fix-bigendian.patch: fix in release Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
5 files changed, 127 insertions, 33 deletions
diff --git a/utils/sane-backends/Makefile b/utils/sane-backends/Makefile
index 4783eff8f..df94f7733 100644
--- a/utils/sane-backends/Makefile
+++ b/utils/sane-backends/Makefile
@@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sane-backends
-PKG_VERSION:=1.0.30
-PKG_RELEASE:=2
+PKG_VERSION:=1.0.31
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://gitlab.com/sane-project/backends/uploads/c3dd60c9e054b5dee1e7b01a7edc98b0
-PKG_HASH:=3f5d96a9c47f6124a46bb577c776bbc4896dd17b9203d8bfbc7fe8cbbcf279a3
+PKG_SOURCE_URL:=https://gitlab.com/sane-project/backends/uploads/8bf1cae2e1803aefab9e5331550e5d5d/
+PKG_HASH:=4a3b10fcb398ed854777d979498645edfe66fcac2f2fd2b9117a79ff45e2a5aa
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
PKG_LICENSE:=GPL-2.0 GPL-2.0-or-later
@@ -179,7 +179,7 @@ CONFIGURE_ARGS += \
--enable-static \
--disable-preload \
--without-snmp \
- --disable-avahi \
+ --without-avahi \
--disable-locking \
--without-usb-record-replay \
@@ -312,6 +312,7 @@ $(eval $(call SaneBackend,canon630u,the Canon 630u USB flatbed scanner,+libusb-1
$(eval $(call SaneBackend,canon_dr,Canon DR-series scanners,+libusb-1.0))
# Depends on libieee1284
#$(eval $(call SaneBackend,canon_pp,Canon CanoScan Parallel Port flatbed scanners,+libieee1284))
+$(eval $(call SaneBackend,canon_lide70,Canon LiDE 70 USB flatbed scanner,))
$(eval $(call SaneBackend,cardscan,Corex CardScan usb scanners,+libusb-1.0))
$(eval $(call SaneBackend,coolscan,Nikon film-scanners,+libusb-1.0))
$(eval $(call SaneBackend,coolscan2,Nikon Coolscan film scanners,+libusb-1.0))
@@ -327,7 +328,7 @@ $(eval $(call SaneBackend,epsonds,EPSON scanners,+libjpeg +libusb-1.0)) ####
$(eval $(call SaneBackend,epson2,EPSON scanners,+libusb-1.0))
#$(eval $(call SaneBackend,escl,AirScan/eSCL devices,+libcurl +libxml2 +libnetsnmp +libavahi))
$(eval $(call SaneBackend,fujitsu,Fujitsu flatbed and ADF scanners,+libusb-1.0))
-$(eval $(call SaneBackend,genesys,GL646 GL841 GL843 GL847 and GL124 based USB flatbed scanners,+libstdcpp +libusb-1.0))
+$(eval $(call SaneBackend,genesys,GL646 GL841 GL843 GL847 and GL124 based USB flatbed scanners,+libstdcpp +libusb-1.0 +libtiff))
$(eval $(call SaneBackend,gphoto2,digital cameras supported by gphoto2,+libjpeg +libgphoto2))
$(eval $(call SaneBackend,gt68xx,GT-68XX based USB flatbed scanners,+libusb-1.0))
$(eval $(call SaneBackend,hp,HP ScanJet scanners,+libusb-1.0))
diff --git a/utils/sane-backends/patches/002-remove-uneeded.patch b/utils/sane-backends/patches/002-remove-uneeded.patch
index 5613e732e..418fd8a15 100644
--- a/utils/sane-backends/patches/002-remove-uneeded.patch
+++ b/utils/sane-backends/patches/002-remove-uneeded.patch
@@ -1,6 +1,8 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -448,7 +448,7 @@ target_alias = @target_alias@
+Index: sane-backends-1.0.31/Makefile.in
+===================================================================
+--- sane-backends-1.0.31.orig/Makefile.in
++++ sane-backends-1.0.31/Makefile.in
+@@ -442,7 +442,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
diff --git a/utils/sane-backends/patches/100-fix-bigendian.patch b/utils/sane-backends/patches/100-fix-bigendian.patch
deleted file mode 100644
index 6363d143f..000000000
--- a/utils/sane-backends/patches/100-fix-bigendian.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From e1934720c687ed8c6125c75ac658f55b4e1513ce Mon Sep 17 00:00:00 2001
-From: Luiz Angelo Daros de Luca <luizluca@gmail.com>
-Date: Sun, 2 Feb 2020 21:19:15 -0300
-Subject: [PATCH] genesys: fix bigendian build
-
-Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
----
- backend/genesys/low.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/backend/genesys/low.cpp
-+++ b/backend/genesys/low.cpp
-@@ -539,7 +539,7 @@ Image read_unshuffled_image_from_scanner
- }
-
- #ifdef WORDS_BIGENDIAN
-- if (depth == 16) {
-+ if (session.params.depth == 16) {
- dev->pipeline.push_node<ImagePipelineNodeSwap16BitEndian>();
- }
- #endif
diff --git a/utils/sane-backends/patches/101-fix_uclibc_std_rand.patch b/utils/sane-backends/patches/101-fix_uclibc_std_rand.patch
index 89594d43f..8b797a196 100644
--- a/utils/sane-backends/patches/101-fix_uclibc_std_rand.patch
+++ b/utils/sane-backends/patches/101-fix_uclibc_std_rand.patch
@@ -1,8 +1,10 @@
https://gitlab.com/sane-project/backends/issues/237
---- a/backend/genesys/image_pipeline.cpp
-+++ b/backend/genesys/image_pipeline.cpp
-@@ -703,7 +703,11 @@ bool ImagePipelineNodeCalibrate::get_nex
+Index: sane-backends-1.0.31/backend/genesys/image_pipeline.cpp
+===================================================================
+--- sane-backends-1.0.31.orig/backend/genesys/image_pipeline.cpp
++++ sane-backends-1.0.31/backend/genesys/image_pipeline.cpp
+@@ -754,7 +754,11 @@ bool ImagePipelineNodeCalibrate::get_nex
float value_f = static_cast<float>(value) / max_value;
value_f = (value_f - offset_[curr_calib_i]) * multiplier_[curr_calib_i];
diff --git a/utils/sane-backends/patches/102-pixma_Restore_old_behaviour_in_case_XML_support_is_missing.patch b/utils/sane-backends/patches/102-pixma_Restore_old_behaviour_in_case_XML_support_is_missing.patch
new file mode 100644
index 000000000..dd53747a8
--- /dev/null
+++ b/utils/sane-backends/patches/102-pixma_Restore_old_behaviour_in_case_XML_support_is_missing.patch
@@ -0,0 +1,110 @@
+From a380fb089499f6b5192c07ae2feaa3376997382f Mon Sep 17 00:00:00 2001
+From: Olaf Meeuwissen <paddy-hack@member.fsf.org>
+Date: Sun, 13 Sep 2020 18:47:32 +0900
+Subject: [PATCH] pixma: Restore old behaviour in case XML support is missing
+
+Fixes #345.
+---
+ backend/pixma/pixma_common.c | 4 ++--
+ backend/pixma/pixma_common.h | 2 ++
+ backend/pixma/pixma_mp150.c | 8 ++++++++
+ backend/pixma/pixma_mp800.c | 8 ++++++++
+ 4 files changed, 20 insertions(+), 2 deletions(-)
+
+diff --git a/backend/pixma/pixma_common.c b/backend/pixma/pixma_common.c
+index ff3bd487d..2f46082e2 100644
+--- a/backend/pixma/pixma_common.c
++++ b/backend/pixma/pixma_common.c
+@@ -56,8 +56,6 @@
+
+ #if defined(HAVE_LIBXML2)
+ # include <libxml/parser.h>
+-#else
+-# error "The pixma backend requires libxml2"
+ #endif
+
+ #include "pixma_rename.h"
+@@ -1241,6 +1239,7 @@ pixma_get_device_status (pixma_t * s, pixma_device_status_t * status)
+ return s->ops->get_status (s, status);
+ }
+
++#if defined(HAVE_LIBXML2)
+ static const char *
+ format_xml_response(const char *resp_details)
+ {
+@@ -1334,3 +1333,4 @@ clean:
+ xmlFreeDoc(doc);
+ return status;
+ }
++#endif
+diff --git a/backend/pixma/pixma_common.h b/backend/pixma/pixma_common.h
+index bee839c2c..1ced88d17 100644
+--- a/backend/pixma/pixma_common.h
++++ b/backend/pixma/pixma_common.h
+@@ -205,7 +205,9 @@ uint8_t *pixma_newcmd (pixma_cmdbuf_t *, unsigned cmd,
+ int pixma_exec (pixma_t *, pixma_cmdbuf_t *);
+ int pixma_exec_short_cmd (pixma_t *, pixma_cmdbuf_t *, unsigned cmd);
+ int pixma_map_status_errno (unsigned status);
++#if defined(HAVE_LIBXML2)
+ int pixma_parse_xml_response(const char *xml_message);
++#endif
+ /**@}*/
+
+ #define pixma_fill_checksum(start, end) do { \
+diff --git a/backend/pixma/pixma_mp150.c b/backend/pixma/pixma_mp150.c
+index cd6cd3ddf..a18fbdce1 100644
+--- a/backend/pixma/pixma_mp150.c
++++ b/backend/pixma/pixma_mp150.c
+@@ -322,6 +322,10 @@
+ <ivec:param_set servicetype=\"scan\"><ivec:jobID>00000001</ivec:jobID>\
+ </ivec:param_set></ivec:contents></cmd>"
+
++#if !defined(HAVE_LIBXML2)
++#define XML_OK "<ivec:response>OK</ivec:response>"
++#endif
++
+ enum mp150_state_t
+ {
+ state_idle,
+@@ -459,7 +463,11 @@ send_xml_dialog (pixma_t * s, const char * xml_message)
+ PDBG (pixma_dbg (10, "XML message sent to scanner:\n%s\n", xml_message));
+ PDBG (pixma_dbg (10, "XML response back from scanner:\n%s\n", mp->cb.buf));
+
++#if defined(HAVE_LIBXML2)
+ return pixma_parse_xml_response((const char*)mp->cb.buf) == PIXMA_STATUS_OK;
++#else
++ return (strcasestr ((const char *) mp->cb.buf, XML_OK) != NULL);
++#endif
+ }
+
+ static int
+diff --git a/backend/pixma/pixma_mp800.c b/backend/pixma/pixma_mp800.c
+index 8b7b232fd..e05107d04 100644
+--- a/backend/pixma/pixma_mp800.c
++++ b/backend/pixma/pixma_mp800.c
+@@ -152,6 +152,10 @@
+ <ivec:param_set servicetype=\"scan\"><ivec:jobID>00000001</ivec:jobID>\
+ </ivec:param_set></ivec:contents></cmd>"
+
++#if !defined(HAVE_LIBXML2)
++#define XML_OK "<ivec:response>OK</ivec:response>"
++#endif
++
+ enum mp810_state_t
+ {
+ state_idle,
+@@ -291,7 +295,11 @@ static int send_xml_dialog (pixma_t * s, const char * xml_message)
+ PDBG(pixma_dbg (10, "XML message sent to scanner:\n%s\n", xml_message));
+ PDBG(pixma_dbg (10, "XML response back from scanner:\n%s\n", mp->cb.buf));
+
++#if defined(HAVE_LIBXML2)
+ return pixma_parse_xml_response((const char*)mp->cb.buf) == PIXMA_STATUS_OK;
++#else
++ return (strcasestr ((const char *) mp->cb.buf, XML_OK) != NULL);
++#endif
+ }
+
+ static void new_cmd_tpu_msg (pixma_t *s, pixma_cmdbuf_t * cb, uint16_t cmd)
+--
+GitLab
+