aboutsummaryrefslogtreecommitdiff
path: root/utils/readsb
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:27:01 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commite7d9c865036d7bc2ac30604e8573f25ae601aed1 (patch)
tree5efb8a25df387e8e79356447c648ecc3306176b3 /utils/readsb
parent35f4ef76e0c88b690ec55f26aed072c4c5989eff (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=lto
See commit 07730ff3 "treewide: add support for "lto" in PKG_BUILD_FLAGS" on the main repository. Note: Some packages only added `-flto` to CFLAGS and not LDFLAGS. This fixes it and properly enables LTO. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'utils/readsb')
-rw-r--r--utils/readsb/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/utils/readsb/Makefile b/utils/readsb/Makefile
index 47b966728..844fc0d51 100644
--- a/utils/readsb/Makefile
+++ b/utils/readsb/Makefile
@@ -20,7 +20,7 @@ PKG_MAINTAINER:=Stijn Tintel <stijn@linux-ipv6.be>
PKG_BUILD_DEPENDS:=!USE_GLIBC:argp-standalone
PKG_BUILD_PARALLEL:=1
-PKG_BUILD_FLAGS:=gc-sections
+PKG_BUILD_FLAGS:=gc-sections lto
include $(INCLUDE_DIR)/package.mk
@@ -49,7 +49,6 @@ MAKE_FLAGS += \
RTLSDR=yes \
UNAME="Linux"
-TARGET_CFLAGS += -flto
TARGET_LDFLAGS += \
$(if $(CONFIG_USE_GLIBC),,-largp) \
-Wl,--as-needed