aboutsummaryrefslogtreecommitdiff
path: root/utils/readsb
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:09:13 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commit35f4ef76e0c88b690ec55f26aed072c4c5989eff (patch)
treec5b36bb3b16488c4546c3c283b8a6020e3966143 /utils/readsb
parent565866a47210c9711c29173052063779b6d3bcfc (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=gc-sections
See commit da370098 "treewide: add support for "gc-sections" in PKG_BUILD_FLAGS" on the main repository. Note: This only touches packages which use all three parts (-ffunction-sections, -fdata-sections and -Wl,--gc-sections) enabled by this build flag. Some packages only use a subset, and these are left unchanged for now. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'utils/readsb')
-rw-r--r--utils/readsb/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/utils/readsb/Makefile b/utils/readsb/Makefile
index e9ed05bde..47b966728 100644
--- a/utils/readsb/Makefile
+++ b/utils/readsb/Makefile
@@ -20,6 +20,7 @@ PKG_MAINTAINER:=Stijn Tintel <stijn@linux-ipv6.be>
PKG_BUILD_DEPENDS:=!USE_GLIBC:argp-standalone
PKG_BUILD_PARALLEL:=1
+PKG_BUILD_FLAGS:=gc-sections
include $(INCLUDE_DIR)/package.mk
@@ -48,10 +49,10 @@ MAKE_FLAGS += \
RTLSDR=yes \
UNAME="Linux"
-TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
+TARGET_CFLAGS += -flto
TARGET_LDFLAGS += \
$(if $(CONFIG_USE_GLIBC),,-largp) \
- -Wl,--gc-sections,--as-needed
+ -Wl,--as-needed
define Package/readsb/conffiles
/etc/config/readsb