aboutsummaryrefslogtreecommitdiff
path: root/utils/oci-runtime-tools
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2021-02-24 15:38:00 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2021-02-24 19:43:54 -0300
commitbb9641e7021293fe1afa6b77e24896874d238c37 (patch)
treeeca60f48f3e75095c080b1a762d4df662f3c6f63 /utils/oci-runtime-tools
parentd9f7dff4a09c82c736560bfe1362873453f6374b (diff)
oci-runtime-tools: fix build with golang 1.16
Add GO111MODULE=auto to GO_PKG_BUILD_VARS to allow the package to be built in non-module mode. Module-aware mode will be mandatory in the next golang release. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'utils/oci-runtime-tools')
-rw-r--r--utils/oci-runtime-tools/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/utils/oci-runtime-tools/Makefile b/utils/oci-runtime-tools/Makefile
index 35d8f7f64..6621ece90 100644
--- a/utils/oci-runtime-tools/Makefile
+++ b/utils/oci-runtime-tools/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=oci-runtime-tools
PKG_VERSION:=1.0.0-pre20210122
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
@@ -54,6 +54,8 @@ define Package/oci-runtime-tests/description
installable via npm.
endef
+GO_PKG_BUILD_VARS += GO111MODULE=auto
+
define Build/Compile
$(call GoPackage/Build/Compile)
$(call GoPackage/Package/Install/Bin,$(PKG_INSTALL_DIR))